R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 05-11-2010, 03:16 PM   #1
Tech Rookie
Join Date: May 2010
Posts: 1
Default Beginner- Issue with pull start

Hi all,
Im new to the RC car business, well i built my car about 2-3 years ago and have never used it as i never got round to getting the final few replacement parts, i got it going last week after getting the few parts i needed, one of which was a new pull start..

now, the problem is, i think some fuel may have got on the chord as it snapped on me earlier today, i was just wondering, should this happen again, is there a way to clean it off so it doesn't get damaged?

I have a thunder tiger pro-12 engine if that makes a differance (shouldnt imagine it would though)

mikejt is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Beginner problem, any help really appriciated. biofish Nitro Off-Road 15 10-12-2009 09:45 AM
Sportsmanship or stupid? skeller Nitro Off-Road 217 08-08-2008 12:26 AM
Western Canadian Indoor Championship Series tandman Canadian R/C Scene 615 09-08-2006 11:26 AM
HELP! New Rc Racer Azazel Australian Racing 8 07-30-2006 07:46 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 11:37 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0