R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 12-12-2009, 09:04 PM   #1
Tech Rookie
Join Date: Dec 2009
Posts: 5
Default revo 3.3 running to hot!!

i'm having problems with my revo running too hot. I set the carb at factory settings but when i run at full throttle the engine doesnt want to run at full rpm, and wont shift. but its running around 250 deg.. i adjusted the hsn an 1/8th turn leaner and the truck runs awesome, i can wheelie it no problem and it takes and off and shifts smoothly , but after 10 min its sitting at like 360 deg, and thats checking at the glow plug....any suggestions what the prob might be..truck is fairly new

Last edited by knezfx; 12-12-2009 at 09:28 PM.
knezfx is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Savage XL or New Revo 3.3? joshjohnson93 Monster Trucks 65 02-09-2012 07:07 PM
revo 3.3 motor temps ceh478133 Nitro Off-Road 6 07-04-2009 07:04 PM
Revo 3.3 Help liftedcj7on44s Monster Trucks 8 04-15-2009 08:22 PM
Ultimate hopped up Revo 3.3 sale everything included!!! sm1nts2escape R/C Items: For Sale/Trade 13 08-27-2008 12:43 PM
Revo 3.3 Engine Cuts off dmx434343 Monster Trucks 13 10-06-2007 08:28 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 02:42 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0