R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 02-17-2004, 02:48 AM   #1
Tech Apprentice
lachlan90's Avatar
Join Date: Jan 2004
Posts: 55
Default stering and acceleration not working

My problen is that my stering on the control does not turn the wheels when i steer. But when i accelerate it turns as weel as accelerate. I think this might be due to a day before. fuel went everywhere and i think it might ave gotten into the servos and recked them. is this what could be happening. can i do anything to fix this without buying a new servo.

lachlan90 is offline   Reply With Quote
Old 02-17-2004, 06:43 AM   #2
Tech Apprentice
Join Date: Jun 2003
Location: Atlanta, GA
Posts: 68

If fuel got everywhere then it is probably your receiver, not your servo, that is giving you problems. I would try cleaning both of them out with some plastic safe electronics cleaner.
trey is offline   Reply With Quote
Old 02-17-2004, 08:49 AM   #3
Tech Elite
popsracer's Avatar
Join Date: Oct 2002
Location: "Hot, Sunny Southern California"
Posts: 3,120
Default steering and acceleration not working


Servos (even standard) are usually fairly fuel proof. The more expensive servos even come with rubber "O"-rings to seal them up.

You receiver is NOT. It is very easy for liquid to enter the case at the plug or crystal openings. Obviously, liquids and electronics do not mix.
The best solution is to spray out the case and electronics and throughly let them dry before using it again. Invest in a Receiver cover to avoid future accidents.

You next item to check is the Batteries in the car. If they are Alkaline/disposables, it may be time for a fresh set.
popsracer is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
more acceleration, same top speed? streetracer745 Monster Trucks 8 04-14-2007 08:52 PM
slow on the acceleration cheehtae Monster Trucks 9 05-18-2005 06:05 AM
m8 STERING WHEEL HELP LosiRacerX Chat Lounge 1 02-20-2005 04:08 PM
More stering in XXX-s please Aprather24 Electric On-Road 17 08-29-2004 09:54 AM
stering and acceleration srewed lachlan90 Australian Racing 5 02-18-2004 08:29 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 12:25 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0