R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 06-25-2009, 10:11 AM   #1
Join Date: Apr 2006
Posts: 16
Unhappy HPI RS4 RTR EVO+ 2009 Vette *NEW* BLOWN

Got this brand new 2009 model HPI evo+

hxxp://www . hpiracing. com/kitinfo/10053/
(remove spaces)
before i proceed just wanna say this was my first car. I followed everything it said on the manual during break-in after like 3 or 4 mins the engine blew. The rotostart just stuck.

I took it to nearest hobbytown the guy said the engine is of no use u could see the broken parts inside.

I called HPI they asked me to send it in and they will look into it . Its been a week lets see what tehy do.

I made this tread to ask what are my other choices for the car engine. I dont want to use same engine coz teh guy said this is 4th car he say which had same fate.

Please advice
StopBuggingMe is offline   Reply With Quote
Old 06-25-2009, 10:51 AM   #2
Tech Master
rcrevolution's Avatar
Join Date: Jul 2005
Location: Somewhere Delicious
Posts: 1,281
Trader Rating: 1 (100%+)
Send a message via AIM to rcrevolution

something from o.s. will put a big smile on your face
rcrevolution is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 08:33 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0