R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 05-06-2009, 09:25 AM   #1
Tech Rookie
Join Date: Dec 2008
Posts: 18
Default car not starting

hi i have recently broke the pullstart on my old cen and we have tried to use a drill but it is not working, the engine heats up and smoke is viewable from the exhaust but it is not firing up
hypergpx4 is offline   Reply With Quote
Old 05-06-2009, 09:40 AM   #2
Tech Regular
Join Date: Nov 2008
Location: Virginia, USA
Posts: 480
Trader Rating: 3 (100%+)

If your engine is not starting, then that's not smoke you're seeing from exhaust but more likely excess unburnt fuel.

Check your glowplug and glowplug ignitor. The plug may be dead or GP ignitor may need to be recharged. If both are new and freshly charged, then its time to adjust your carb needles. They might be set too rich, causing the engine to flood.

Check your manual for factory settings and work your way from there, which is usually good settings for getting engines started then tune (adjust) engine from there.

Hope this helps

Last edited by Kyo83; 05-07-2009 at 08:53 AM. Reason: spelling/grammar
Kyo83 is offline   Reply With Quote
Old 05-06-2009, 09:50 AM   #3
Tech Rookie
Join Date: Dec 2008
Posts: 18

thank you
hypergpx4 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
new ofna DM1 pics and thoughts :):) dremelboy Nitro On-Road 1562 11-01-2015 06:44 PM
Atria Car Park Speedway tIANcI Malaysian R/C Racers 26519 12-07-2013 06:04 PM
YOKOMO MR4-BX stegger Electric Off-Road 592 05-04-2012 10:10 AM
Jammin' X2 Buggy NsideLine Nitro Off-Road 479 09-02-2010 10:36 AM
Ask Mike Blackstock Mike Blackstock Electric On-Road 909 10-02-2005 09:23 AM
ASEAN CUP 1/10 nitro bulldog1 Malaysian R/C Racers 93 03-22-2004 12:06 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 06:28 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0