R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 01-02-2010, 11:52 PM   #901
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

mine is standing up.
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Old 01-06-2010, 08:10 AM   #902
Tech Fanatic
 
SERPENT7twenty's Avatar
 
Join Date: Jul 2009
Location: Newport Beach, CA
Posts: 812
Trader Rating: 20 (100%+)
Default

Has anyone tried the XCEED 1-piece brake disc? If so .. your personal thoughts?

Thanks!
__________________
TEAM KAMIKAZE - SERPENT 966 - NOVAROSSI - HUDY - KO PROPO - XCEED
Kamikaze Development Driver - R&D = Rebuild & Destroy
www.Kamikazetoysandhobbies.com
SERPENT7twenty is offline   Reply With Quote
Old 01-06-2010, 09:43 AM   #903
Tech Master
 
Join Date: Jan 2008
Location: Moreno Valley, Ca.
Posts: 1,937
Trader Rating: 3 (100%+)
Send a message via Yahoo to motojon
Default

Quote:
Originally Posted by keavze View Post
hi guys,
just wana check whether majority is running the throttle servo laying down or standing up?

any difference in handling and performance?
currently i'm running mine standing up as i needed the space for my receiver (with box)
Test it and see what happens.... never hurts to try
__________________
My Gpa(RIP)
motojon is offline   Reply With Quote
Old 01-06-2010, 11:02 AM   #904
Tech Elite
 
dj apolaro's Avatar
 
Join Date: May 2005
Location: Miami, Fl.
Posts: 2,381
Default

I run mine standing up. Mainly since I do not like the receiver under the upper deck next to the pipe. Just a personal think for me. I have never tried the lay down style though.

DJ Apolaro
__________________
Capricorn RC, Capricorn Tires, Novarossi World, Spektrum, Horizon Hobby, PROTOform, RCTarget, IGT8.
dj apolaro is offline   Reply With Quote
Old 01-06-2010, 06:48 PM   #905
Tech Rookie
 
royco's Avatar
 
Join Date: Sep 2009
Posts: 17
Default

Quote:
Originally Posted by SERPENT7twenty View Post
Has anyone tried the XCEED 1-piece brake disc? If so .. your personal thoughts?

Thanks!
i have tried it for two weekends and braking is smooth......... but maybe too soon to say need more time on the track.
__________________
Roy

---------------------------------
Serpent 966,Maxpower XL9 TQ and XL7, Futaba 4pk
royco is offline   Reply With Quote
Old 01-07-2010, 12:41 AM   #906
Tech Addict
 
keavze's Avatar
 
Join Date: May 2007
Posts: 590
Default

Quote:
Originally Posted by dj apolaro View Post
I run mine standing up. Mainly since I do not like the receiver under the upper deck next to the pipe. Just a personal think for me. I have never tried the lay down style though.

DJ Apolaro

never liked the receiver next to a hot pipe!
__________________
>>> the "SNAKE" doesn't bite; it STINGS! <<<
keavze is offline   Reply With Quote
Old 01-07-2010, 03:19 AM   #907
Tech Adept
 
Join Date: May 2003
Location: london, uk
Posts: 225
Default balancing left/right

Hi all,
Got reciever mounted on the left hand side. Been trying to balance the right but look like i am going to need 110g on the right !!!

Anybody balanced their car, just wanna roughly how much weight used. I know different servos and engine pipe combo will affect overall weight required.

Thanks
xtreme888 is offline   Reply With Quote
Old 01-07-2010, 06:49 AM   #908
Tech Master
 
Join Date: Jan 2008
Location: Moreno Valley, Ca.
Posts: 1,937
Trader Rating: 3 (100%+)
Send a message via Yahoo to motojon
Default

Are u running the brass wheight on the right side also i now thats an additional 50g on the right
__________________
My Gpa(RIP)
motojon is offline   Reply With Quote
Old 01-07-2010, 09:02 AM   #909
Tech Elite
 
dj apolaro's Avatar
 
Join Date: May 2005
Location: Miami, Fl.
Posts: 2,381
Default

I use the brass weight on the right side of the car.

DJ Apolaro
__________________
Capricorn RC, Capricorn Tires, Novarossi World, Spektrum, Horizon Hobby, PROTOform, RCTarget, IGT8.
dj apolaro is offline   Reply With Quote
Old 01-07-2010, 09:45 AM   #910
Tech Champion
 
RC MARKET's Avatar
 
Join Date: Feb 2007
Location: HK
Posts: 6,150
Trader Rating: 12 (100%+)
Default

Serpent
UPRIGHT 966 OS2 WIDE OFFSET (2)
Attached Thumbnails
Serpent 966-ser-903351.jpg  
RC MARKET is offline   Reply With Quote
Old 01-07-2010, 12:30 PM   #911
Tech Elite
 
dj apolaro's Avatar
 
Join Date: May 2005
Location: Miami, Fl.
Posts: 2,381
Default

I used these at our last state race and they worked great. They give more mid corner steering and I felt the car did not loose and stability. They are worth the try.

The only thing I recommend is trim about 1 to 2 mm of the arm's to make sure you can the track width you want. If not you may have to run about 266 or 267 on the track width. For me that is too much.


DJ Apolaro
__________________
Capricorn RC, Capricorn Tires, Novarossi World, Spektrum, Horizon Hobby, PROTOform, RCTarget, IGT8.
dj apolaro is offline   Reply With Quote
Old 01-08-2010, 06:38 AM   #912
Tech Master
 
Pyramid's Avatar
 
Join Date: Sep 2001
Location: ID
Posts: 1,945
Default

Quote:
Originally Posted by xtreme888 View Post
Hi all,
Got reciever mounted on the left hand side. Been trying to balance the right but look like i am going to need 110g on the right !!!

Anybody balanced their car, just wanna roughly how much weight used. I know different servos and engine pipe combo will affect overall weight required.

Thanks
Mega DS engine, Sirio 2058 pipe, Futaba 452 servos, amb transp on the right, vxr/xceed regulator on the left, helios rx on the right, it needs exactly 60gr on the right to have equal balance.
Pyramid is offline   Reply With Quote
Old 01-10-2010, 07:51 PM   #913
Tech Adept
 
Join Date: Dec 2009
Posts: 228
Default

Hi guys,

I've gotten a new 966 about a month back and only managed to finally run the car last weekend down at my local track.

When I was trying to start the car up,it didnt start.Replaced new plugs and checked the fuel line and found out there wasnt any fuel going into the engine.Tried blowing thru the exhaust,but still no fuel going in.Disconnected the tubing on my exhaust,checked the pipe for any blockage but none.Blew thru the tubing,fuel starts to flow but slowly and with much force.

Once gotten some fuel in,the car starts.But,the engine was experiencing some bog somesort like asthma,it just didnt run as usual.Did a re-tune,checked the carburators and needles.The car finally ran,but at certain rpms,the car or engine didn't run well.

Some guys at the track mentioned that it mite be fuel pressure problem or even the engine.For the engine part,its still considered new and i just cleaned it after a 20mins main on a recent race last month.So guys,need help on this.
tq23 is offline   Reply With Quote
Old 01-11-2010, 07:01 AM   #914
Tech Champion
 
RC MARKET's Avatar
 
Join Date: Feb 2007
Location: HK
Posts: 6,150
Trader Rating: 12 (100%+)
Default

Quote:
Originally Posted by SERPENT7twenty View Post
Has anyone tried the XCEED 1-piece brake disc? If so .. your personal thoughts?

Thanks!
Yes used in 733 feel ok !
CSO today released 1pc brake disc LW !
RC MARKET is offline   Reply With Quote
Old 01-11-2010, 07:36 AM   #915
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

Quote:
Originally Posted by tq23 View Post
Hi guys,

I've gotten a new 966 about a month back and only managed to finally run the car last weekend down at my local track.

When I was trying to start the car up,it didnt start.Replaced new plugs and checked the fuel line and found out there wasnt any fuel going into the engine.Tried blowing thru the exhaust,but still no fuel going in.Disconnected the tubing on my exhaust,checked the pipe for any blockage but none.Blew thru the tubing,fuel starts to flow but slowly and with much force.

Once gotten some fuel in,the car starts.But,the engine was experiencing some bog somesort like asthma,it just didnt run as usual.Did a re-tune,checked the carburators and needles.The car finally ran,but at certain rpms,the car or engine didn't run well.

Some guys at the track mentioned that it mite be fuel pressure problem or even the engine.For the engine part,its still considered new and i just cleaned it after a 20mins main on a recent race last month.So guys,need help on this.
try blowing back through the engine line side. if it is easier to blow that way, then look at your lid. maybe some plastic stuck inside the nipple behind in the cap. if in doubt try anothe lid. or see if you can sopurce a new tank.
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Serpent 960.... M7H Nitro On-Road 3281 11-14-2013 10:23 AM
Team Kamikaze Rc Racing Team Kamikaze Racing Forum 17924 08-31-2012 03:25 PM
Serpent's Lair ordinaryzam Malaysian R/C Racers 316 10-30-2009 12:29 AM
1/8th & 1/10th 200mm GAS POWERED ON ROAD OPEN RACE Kylelim Singapore R/C Racers 98 04-24-2009 11:10 PM
Melaka Club Race 1/8, 1/10 GP and EP 2WD MINI - 1st March 09 zali_sh Malaysian R/C Racers 185 03-09-2009 10:36 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:45 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net