R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 03-28-2008, 07:53 PM   #1
Tech Initiate
Join Date: Nov 2007
Posts: 38
Trader Rating: 2 (100%+)
Default Mugen MTX2 - STS engine, HELP PLEASE

Hi guys, tried a search, but couldn't find what i need...

I have a mtx2 that i just bought second hand, and it has on it a STS 12 engine (that is also model type name). I can not get it going...

It starts first go every time, but when i open the throatle to the wide open position, it stalls. I have tried every thing with the tuning and nothing helps.

I tried to increase the revs slowly, but it doesn't help, the best i got was about 20 feet, and then just as it started to get some decent speed it stalls.

i can only put it down to something stupid like clutch or glow plug(?) but i just cannot fix the problem. I made sure there was no extra load on the drive train at that thraotle position, but still nothing...

ANY IDEAS - i was hoping to race this tomorrow!!! If it helps, i has been sitting for arround 18 months...
Thnks in advance

Last edited by matb543; 03-28-2008 at 07:54 PM. Reason: spelling mistake
matb543 is offline   Reply With Quote
Old 03-29-2008, 11:03 AM   #2
Tech Master
CREWMAN's Avatar
Join Date: Aug 2007
Posts: 1,539
Trader Rating: 19 (100%+)

Start with the glow plug. Are you fuel lines old or new. you may need to replace all your fuel lines. if it has a fuel filter make sure that that is clean
Losi 8ight-T 2.0 Race Roller/Losi 350/JR 9100 Servos/Spektrum DX3R
BMI Copperhead 12/Thunder Power Lipo/Futaba Servo/Express 17.5/Spektrum DX3R
CREWMAN is offline   Reply With Quote
Old 03-29-2008, 03:30 PM   #3
Tech Elite
quietstorm76's Avatar
Join Date: Apr 2005
Location: Atlanta
Posts: 2,265
Trader Rating: 10 (100%+)

Glow plug would be my first choice. If that doesn't work it may just need a good tune on it. Also make sure the pipe isn't clogged or bad.
Team Shepherd USA:Nugget's Ranch Raceway
Primary Weapon: ?
Secondary Weapon: ?
Tires>>> I don't know yet
quietstorm76 is offline   Reply With Quote
Old 03-29-2008, 05:14 PM   #4
Tech Addict
kcrunchone's Avatar
Join Date: Oct 2005
Posts: 527
Trader Rating: 1 (100%+)

clean the tank out. after sitting that long you may have residual settlement of globs of sludge stopping fuel from flowing from tank to engine.
like the guys said change lines, plug, remove the filter and make sure carb is open too.

Rick Hill

"Failure Is Not An Option"
kcrunchone is offline   Reply With Quote
Old 03-29-2008, 11:57 PM   #5
Tech Initiate
Join Date: Nov 2007
Posts: 38
Trader Rating: 2 (100%+)

Hi Guys,

Thanks for your input. Went to the track, the guys there helped me out. It turns out it was the clutch and lean tune.

thanks agian
matb543 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mugen MTX2 matb543 Australia For Sale/Trade 5 07-23-2008 07:26 PM
WTB Mugen MTX2/MTX2 Prospec matb543 Australia Wanted to Buy 2 03-27-2008 04:53 PM
mtx2 mugen $150 only pme R/C Items: For Sale/Trade 0 08-07-2005 08:27 AM
Mugen MTX2 Dave Walton R/C Items: For Sale/Trade 1 08-19-2003 06:43 PM
Mugen MTX2 TheBarber R/C Items: For Sale/Trade 3 06-19-2002 07:49 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 05:57 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0