R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 04-16-2003, 06:50 PM   #1
Tech Apprentice
Join Date: Feb 2003
Location: New York City
Posts: 70
Send a message via ICQ to drive4fun
Default Question just broke in my NTC3 RTR

Ok i just got my ntc3 rtr my first nitro and it was a beautiful weather so i decided to break my engine with a friend it was 75* F and it wasnt raining perfect justa bit cloudy ok i had trouble at first fuel didnt go through in the carb so i opened the lid a couple of times then it flooded so i took out the plug and filter and emptied it out... ok so i read the break in etc then i got pebbles stuck in my spur gear and then my car wouldnt go and it started to overheat i think so i stoped it and i took them out and i started again well after it started to rain after the 3 tanks of breaking in so i stoped when i got inside i notice that the *clutch*( i think) its about 1 inch between the pinion and the flywheel it turned colors half of it now is blue and half of it is yellow what is my problem i wonder if i did it to hot my engine i made a mistake or something or is this normal car runeed smooth until the pebbles but im curious and worried about what happened? is this a big deal what should i do? what is it? i hoped i explained myself enough any questions feel free to ask i need your help thank you
drive4fun is offline   Reply With Quote
Old 04-16-2003, 10:23 PM   #2
Tech Regular
RedScorp's Avatar
Join Date: Mar 2003
Location: So. Cal.
Posts: 283
Send a message via ICQ to RedScorp Send a message via AIM to RedScorp Send a message via Yahoo to RedScorp

If you're asking about the clutch bell, it's normal for the clutch bell to change color after running. Don't forget that your engine is running somewhere between 220 and 270 and the clutch bell is like an arm of the motor. It gets hot just like the motor but it has no cooling like the motor gets. When things get hot they change color. Just keep an eye on your operating temps. and you should be fine.
RedScorp is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
NTC3 question??? BIG DADDY8 Nitro On-Road 3 06-26-2008 07:24 PM
ntc3 question kungfushirtart Nitro On-Road 3 06-11-2006 07:03 AM
Broke my foams, question... Michael Barch Electric On-Road 6 01-03-2006 03:33 PM
NTC3 question Phatkat Nitro On-Road 2 12-08-2003 11:12 PM
I have a question about the ntc3 rctc3 Nitro On-Road 0 04-10-2002 05:58 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 05:49 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0