R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 02-25-2013, 09:41 AM   #1
Tech Regular
 
Join Date: Feb 2013
Location: Park Hills, MO
Posts: 400
Trader Rating: 6 (100%+)
Default truggy sticking wide open?? please help

Hello guys, new to the site.. been in R/c Cars for a while. Just recently bought a 4.6 hpi truggy. have ran 6 tanks through it and all of a sudden the servo got all twitchy so i went and bought two new hi tech servos after i sent my truggy back to hpi and they didnt do anything about it breaking after it got stuck wide open and smashed everyrthing in sight. they gave me the junkest servos ive ever seen but they did send me all the parts to fix it after i called and complained . i took out the truggy yesterday with everything new in stalled and a failsafe and it would go about 20 feet then decide to be stuck around half throttle. could this possibly be my reciever and remote? im clueless at this point.
BlantonBx8 is offline   Reply With Quote
Old 03-22-2013, 05:30 AM   #2
Tech Regular
 
RObErT_RaTh's Avatar
 
Join Date: Apr 2007
Posts: 302
Trader Rating: 40 (100%+)
Default

Could also be your power cutting out, check all wiring from battery to receiver.
__________________
-=[ LOSI 8IGHT 2.0 EU / ALPHA S852+0801 ]=-
RObErT_RaTh is offline   Reply With Quote
Old 03-22-2013, 06:37 AM   #3
Tech Master
 
BillyT.'s Avatar
 
Join Date: Nov 2012
Posts: 1,914
Trader Rating: 4 (100%+)
Default

It sounds like a TX/RX problem.

You didn't cut your antenna wire did you?
__________________
Nemo Racing USA
Agama : Bullitt : Beta
[email protected]
BillyT. is offline   Reply With Quote
Old 03-22-2013, 06:50 AM   #4
Tech Elite
 
Join Date: Jan 2009
Posts: 2,147
Trader Rating: 24 (100%+)
Default

Quote:
Originally Posted by BlantonBx8 View Post
Hello guys, new to the site.. been in R/c Cars for a while. Just recently bought a 4.6 hpi truggy. have ran 6 tanks through it and all of a sudden the servo got all twitchy so i went and bought two new hi tech servos after i sent my truggy back to hpi and they didnt do anything about it breaking after it got stuck wide open and smashed everyrthing in sight. they gave me the junkest servos ive ever seen but they did send me all the parts to fix it after i called and complained . i took out the truggy yesterday with everything new in stalled and a failsafe and it would go about 20 feet then decide to be stuck around half throttle. could this possibly be my reciever and remote? im clueless at this point.
I'm assuming your RX battery is charged and in perfect working condition? Just because it's new does not mean it's taking a proper charge.

Have you checked the carb slide to see if it's getting hung up with nothing connected to it? Have you positioned the carb in the spot where it opens the smoothest and makes the most sense with the servo? Do you have a return spring on? You have to troubleshoot the entire thing.
__________________
.......__________________
....../_==o;;;;;;;;__ _____]
.....), ---.(_(__)
.....// (..)//
....//___// Support NRA!
got_nitro is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:23 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net