R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 09-20-2012, 08:16 PM   #1
Tech Rookie
 
Join Date: Sep 2012
Posts: 11
Default I just wanna go fast!

Ok I just bought a used savage 4.6. I bought it and had to put a owb and some other parts so I didn't get to hear it run. I got it running no problem but runs really rich, really boggy, and dumps fuel out the exhaust. I'm not new to nitros but no expert. I set the carb back to stock and tried to lean out from there but nothing changes, I'm running byrons 30% nitro 11% lube and not sure how old so possibly bad? Looking for s
uggestions
sjxandrew is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
2 complete cars for sale, willing to seperate, need to go fast. SamPD R/C Items: For Sale/Trade 230 10-20-2012 09:18 AM
Hey all need some advice wanna go offroad racing dustinb Nebraska/Iowa Racing 15 01-17-2012 03:54 PM
I Wanna Go Faster on This Track Punkynutt Electric On-Road 41 05-31-2004 12:36 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:57 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net