R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 06-04-2012, 05:35 PM   #1
Tech Rookie
 
Join Date: Jun 2012
Posts: 7
Default Hpi Savage Transmission Trouble

I just put a new transmission in my truck. Transmission will not engauge. Just a little bit of wheel turn at max RPM. what i can do
denteddodge_76 is offline   Reply With Quote
Old 06-04-2012, 08:27 PM   #2
Tech Apprentice
 
OS21Revo's Avatar
 
Join Date: May 2012
Location: Next to a lake
Posts: 76
Trader Rating: 3 (100%+)
Default

hpi savage transmission help needed
OS21Revo is offline   Reply With Quote
Old 06-04-2012, 09:11 PM   #3
Tech Rookie
 
Join Date: Jun 2012
Posts: 7
Default

No the 4.6 savage X
denteddodge_76 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Savage Flux HP Thread 4wdmt Monster Trucks 7326 08-14-2017 10:36 PM
I got a B44, Where to go? What to do? Onetrade Electric Off-Road 51 05-27-2009 12:38 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:02 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net