R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 03-18-2012, 07:52 PM   #1
Tech Regular
 
brooklynny's Avatar
 
Join Date: Mar 2012
Location: Camp Verde, AZ
Posts: 391
Trader Rating: 21 (100%+)
Default d8s problems

I have had the buggy for 3 weeks now and am trying to get it dialed in. I feel like I'm still missing power that I should have with the nitrostar 3.5, does anyone know how fast these engines are?

Since I am new to this I feel like maybe my landings are rough and bent the rear and front drive shafts twice, is this a known issue?
brooklynny is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
BCE racing custom chassis thread moparsrule Nitro Off-Road 1979 04-27-2017 02:43 PM
New Hot Bodies Buggy!!??????? monsteraddict Nitro Off-Road 14489 03-18-2013 01:42 PM
Losi 8T 2.0 RTR vs Hot Bodies D8T mike881 Nitro Off-Road 166 11-28-2011 07:39 PM
2008 IFMAR 1/8 Buggy World Championship - Sept: 15-21 @ The Farm 2 KyLayfield Nitro Off-Road 854 01-12-2009 01:44 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:14 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net