R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 09-10-2011, 04:41 PM   #1
Tech Initiate
 
Join Date: Sep 2011
Posts: 21
Unhappy HELP Firestorm 10T ASAP

Hi i just bought a firestorm 10t and when i start it the wheels spin fast and we keep putting the throttle down but it just ends up quitting help please
nicker411 is offline   Reply With Quote
Old 09-10-2011, 07:27 PM   #2
Tech Apprentice
 
Join Date: Sep 2011
Location: Apple Valley, MN
Posts: 64
Trader Rating: 1 (100%+)
Default

Is this brand new out of the box? I just bought one a few days ago. The DVD that comes with the truck shows how to properly break in the engine and adjust the settings. I wouldn't mess with the carb until you've run a couple of tanks of fuel.
road_rascal is offline   Reply With Quote
Old 09-11-2011, 05:41 AM   #3
Tech Initiate
 
Join Date: Sep 2011
Posts: 21
Default

Ok ill see and yes it is right out of the box
nicker411 is offline   Reply With Quote
Old 09-11-2011, 05:42 AM   #4
Tech Initiate
 
Join Date: Sep 2011
Posts: 21
Default

We did watch the video the engine is just messed on it they didnt set it right it just keeps going we cant get it to idle
nicker411 is offline   Reply With Quote
Old 09-11-2011, 12:55 PM   #5
Tech Apprentice
 
Join Date: Sep 2011
Location: Apple Valley, MN
Posts: 64
Trader Rating: 1 (100%+)
Default

You may have to adjust the throttle trim knob on the TX a bit to get it to idle. Turn it clockwise (I think) to open the throttle just a bit then try starting it. It should idle without spinning the tires. After I broke mine in I adjusted the throttle linkage (grub screw on the pushrod) so that mine will idle if I turn the trim knob fully closed. The manual explains this pretty well, but it does take a bit of futzing to get dialed in.
road_rascal is offline   Reply With Quote
Old 09-11-2011, 01:39 PM   #6
Tech Initiate
 
Join Date: Sep 2011
Posts: 21
Default

I figured it out but my spur gear id melted arround the center what should i do now
Thank you for the help
nicker411 is offline   Reply With Quote
Old 09-11-2011, 02:47 PM   #7
Tech Apprentice
 
Join Date: Sep 2011
Location: Apple Valley, MN
Posts: 64
Trader Rating: 1 (100%+)
Default

The spur gear actually melted? Wow- it sounds like the engine was running way too hot (too lean). Did you get the truck from a local hobby shop or mail order? If local, I would take it to them for help. Hopefully someone else on this forum can help you out. The Firestorm I bought is my first nitro truck, but I've been flying nitro and electric planes for awhile now. My rc car/truck knowledge is pretty limited.
road_rascal is offline   Reply With Quote
Old 09-11-2011, 03:56 PM   #8
Tech Initiate
 
Join Date: Sep 2011
Posts: 21
Default

Yea thats what we're doing tomorrow and yea the middle did melt thanks
nicker411 is offline   Reply With Quote
Old 09-12-2011, 08:33 AM   #9
Tech Regular
 
ohdeeuhm's Avatar
 
Join Date: Dec 2009
Location: Petal, MS
Posts: 303
Trader Rating: 18 (100%+)
Default

Sounds like the clutch bell bearing could have seized up and caused enough heat to melt the spur. This past weekend one of my clutch bell bearings seized up on one of my 1/8 buggies and when ever I tried to crank it the tires would spin pretty fast and if I touched the throttle or anything it would go dead. See if the clutch bell will spin freely without making the engine turn over. That may be part of your problem.
__________________
www.advrider.com
Riverside RC Raceway -- Petal, MS
Braaaaaaaaaaaap!
ohdeeuhm is offline   Reply With Quote
Old 09-12-2011, 01:04 PM   #10
Tech Initiate
 
Join Date: Sep 2011
Posts: 21
Default

Thanks we bought a new one so what do u think i should set it as
nicker411 is offline   Reply With Quote
Old 09-13-2011, 06:49 PM   #11
Tech Apprentice
 
Join Date: Sep 2011
Location: Apple Valley, MN
Posts: 64
Trader Rating: 1 (100%+)
Default

Any updates on the repairs?
road_rascal is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:14 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net