R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 06-01-2011, 05:42 PM   #1
Tech Rookie
 
Join Date: Jun 2011
Posts: 1
Default Startup Help

Hey guys, I have a duratrax evader that I bought a few years back. I used to drive all the time. However, I moved and just got back around to getting it out. I'm having issues starting it though. I pull and pull and nothing happens. Twice it started up but died almost instantly. I checked the plug and its good. I have no idea what the issue is. Thanks in advance.
mcjagers is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
TRAXXAS SUMMIT HELP!!!!!!!! gtcuppels Electric Off-Road 16 11-22-2013 08:52 PM
OMG Please help!!!! b.mcdaniel.2009 Electric Off-Road 52 02-25-2011 03:37 PM
Sidewinder 5700kv help Please And187 Electric Off-Road 17 12-06-2010 03:34 PM
newbie.. help me gix Malaysian R/C Racers 30 06-05-2007 09:03 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:31 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net