R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 05-28-2011, 08:59 AM   #1
Tech Master
 
Jimmy Avila's Avatar
R/C Tech Elite Subscriber
 
Join Date: Nov 2009
Location: Houston,TX
Posts: 1,435
Trader Rating: 81 (100%+)
Default Problem charging lipo glow igniter

I have a dynamite lipo igniter and when I try to charge it my charger says over voltage. It's a Hyperion charger. Any advice?
Jimmy Avila is offline   Reply With Quote
Old 05-28-2011, 04:36 PM   #2
Tech Lord
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,482
Trader Rating: 8 (100%+)
Send a message via MSN to Integra
Default

Quote:
Originally Posted by Jimmy Avila View Post
I have a dynamite lipo igniter and when I try to charge it my charger says over voltage. It's a Hyperion charger. Any advice?


What are your settings on the charger ?
__________________
TNS Driver - Radio Post - Blue Groove Apparel - Team Panther - Hitec - Losi - W.E.D. Paint - Clockwork Fuel - Competition Heat - SUMO Racing - Tekin - Team Terribles - M2C Racing - Matrix Concepts - Kal Gard - BuKu Power - DE Racing -
Integra is offline   Reply With Quote
Old 05-29-2011, 03:46 AM   #3
Tech Master
R/C Tech Elite Subscriber
 
Join Date: Mar 2009
Location: Perth, West Australia.
Posts: 1,243
Trader Rating: 25 (100%+)
Default

Are you sure it's a "LiPo" igniter and not a NiMh one?
__________________
Kyosho MP9, STRR Evo 2
OS Engines, KO Propo
AKA
Nitro X Fuels
smelly62 is offline   Reply With Quote
Old 05-29-2011, 06:28 AM   #4
Tech Master
 
pballer2777's Avatar
 
Join Date: Jan 2009
Location: dirty jerz
Posts: 1,775
Trader Rating: 27 (100%+)
Default

Mine did the same thing. I just stuck with the wall charger.
__________________
tlr 8 4.0 /rex engine/aka
tlr 8e 3.0/tekin/aka
pballer2777 is offline   Reply With Quote
Old 05-29-2011, 06:36 AM   #5
Suspended
 
Join Date: Dec 2009
Location: northern michigan
Posts: 7,916
Trader Rating: 202 (96%+)
Default

Quote:
Originally Posted by pballer2777 View Post
Mine did the same thing. I just stuck with the wall charger.
i just use the wall charger also.
__________________
D8 "HARA", OS SPEED, ,SAVOX 1267/68 SERVOS, BYRONS 25%, SPEKTRUM DX3R PRO
D8T GO GXII ,SAVOX 1267/68 SERVOS, BYRONS 25%, SPEKTRUM DX3R PRO
NMRCC -(northern michigan rc club)
inferno13 is offline   Reply With Quote
Old 05-29-2011, 06:46 AM   #6
Tech Champion
 
adrictan's Avatar
 
Join Date: May 2008
Posts: 5,109
Trader Rating: 10 (100%+)
Default

The charger that came with the set does not have any power rating. I'm not sure if it's my hse power or if it's a defective unit but the charger poofed when I plugged it in to charge after abt 10secs.
__________________
Sponsors: T-Bone Racing, Misfit Design Group, Maclan Racing, IB Prostart, PTRC Oils, Vision Racing Products, SRT Servo, Boca Bearing, Soar Seiki.

Soar Enquiries: adric.tan@soarseiki.com
adrictan is offline   Reply With Quote
Old 05-29-2011, 11:03 AM   #7
Tech Addict
 
Join Date: Dec 2007
Location: Brandon, MS
Posts: 543
Default

I was thinking the charge circuit was built into the igniter and the wall wart only supplied power. If that is the case then you would be trying to charge a charger that was trying to charge the battery.......don't think you can make that work.
bentgear is offline   Reply With Quote
Old 05-29-2011, 11:48 AM   #8
Tech Fanatic
 
Join Date: Jul 2008
Posts: 786
Trader Rating: 2 (100%+)
Default

I've used both a cheapo HobbyKing and a Racers Edge charger with the Dynamite LiPO ignitor without issue. I'm using a universal radio chargig adapter. Perhaps the polarity of the plug tip you are using is reversed?
__________________
Sponsored by My Kids' Inheritance
Serpent S811 Cobra | Novarossi Plus 21-4T | Airtronics M11x | Savox Servos
mthird is offline   Reply With Quote
Old 05-29-2011, 11:50 AM   #9
Tech Adept
 
Join Date: Feb 2009
Posts: 121
Default

Quote:
Originally Posted by bentgear View Post
I was thinking the charge circuit was built into the igniter and the wall wart only supplied power. If that is the case then you would be trying to charge a charger that was trying to charge the battery.......don't think you can make that work.
true but the instrutions say you can charge it at 1 amp through a normal lipo charger which mine wont do either it starts charging then after aroumd 30 to 50 mili amps says its full and its not
the daddy is offline   Reply With Quote
Old 05-29-2011, 04:04 PM   #10
Tech Addict
 
Join Date: Dec 2007
Location: Brandon, MS
Posts: 543
Default

Have the right adapter end so I will have to give it a try and see what happens. It would be nice to know the mah it takes to charge it back. Thanks guys.
bentgear is offline   Reply With Quote
Old 05-29-2011, 07:45 PM   #11
Tech Regular
 
Join Date: Aug 2010
Location: North Queensland
Posts: 362
Trader Rating: 1 (100%+)
Default charge settings

Quote:
Originally Posted by Integra View Post
What are your settings on the charger ?
ime charging at 1200mah lipo
but when i checked the voltage at the glow end it was 4.2v,instructions said it was governed to 1.5v.
still dont glow,just gets warm,?
noddy2 is offline   Reply With Quote
Old 05-29-2011, 08:07 PM   #12
Tech Lord
 
Frank L's Avatar
 
Join Date: Dec 2008
Location: NorCal
Posts: 12,500
Trader Rating: 148 (100%+)
Default

Quote:
Originally Posted by pballer2777 View Post
Mine did the same thing. I just stuck with the wall charger.
Yep. No issues here. I have 2 of them and they both work fine when I use the wall chargers that came with them.
__________________
- X-Ray/ RC America Team Driver - MKS -
- XB8 - XB8T - XB8 E - OS Spec III - B2102 - 4PXR -
~ SSC ~ Godfather ~ Ironman ~ ButterySmooth ~
Frank L is offline   Reply With Quote
Old 05-29-2011, 08:26 PM   #13
Tech Addict
 
Join Date: Dec 2007
Location: Brandon, MS
Posts: 543
Default

Quote:
Originally Posted by noddy2 View Post
but when i checked the voltage at the glow end it was 4.2v,instructions said it was governed to 1.5v.
:
You would need to measure the voltage on the glo plug end when it had the amp draw load of a glo plug placed on it to get a true reading.
bentgear is offline   Reply With Quote
Old 05-30-2011, 12:45 AM   #14
Tech Initiate
 
Join Date: Oct 2010
Posts: 42
Trader Rating: 2 (100%+)
Default

uh-oh, i just bought the ignitor without the wall charger hope it can be charged using a lipo charger using the glow adapter.

Will update as soon as it arrives.
jurutera is offline   Reply With Quote
Old 05-30-2011, 01:24 AM   #15
Tech Regular
 
Join Date: Aug 2010
Location: North Queensland
Posts: 362
Trader Rating: 1 (100%+)
Default 240 v wall charger ?

Quote:
Originally Posted by Frank L View Post
Yep. No issues here. I have 2 of them and they both work fine when I use the wall chargers that came with them.
thanks Frank .how long do they stay charged ? can you get a full days racing out of them ?.

does anyone know if a 240volt charger is available for these units ?Australian compliance.

if not, anyone want to by one,brand new,no charger.

jonando
noddy2 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
The best glow plug ignitor?? barrydidntknow Offroad Nitro Engine Forum 119 06-12-2016 11:23 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:52 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net