R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 03-25-2011, 12:45 AM   #1
Tech Adept
 
Join Date: Jan 2010
Posts: 109
Default nitro buggy problems, help?

hey guys i have an lrp s8bx rtr and whenver i drive it about 15-20 metres away from me it just goes crazy and has a mind of its own, i tried the crystals i swaped the radio and reciever and it still didnt work, does any one know what else it could be, i really need help?!!
marto1996 is offline   Reply With Quote
Old 03-25-2011, 12:52 AM   #2
Tech Addict
 
808gx7r's Avatar
 
Join Date: Jun 2010
Posts: 721
Default

Quote:
Originally Posted by marto1996 View Post
hey guys i have an lrp s8bx rtr and whenver i drive it about 15-20 metres away from me it just goes crazy and has a mind of its own, i tried the crystals i swaped the radio and reciever and it still didnt work, does any one know what else it could be, i really need help?!!
full charged reciever batteries? what you could do is...
http://www.amainhobbies.com/product_...o-w-S200-Servo

and make sure reciever batteries are always charged. then you wont have range/interferance issues
__________________
Mugen Mbx6t / O.S SPEED / Byrons / Savox servos / Futaba
Agama A8 Evo / O.S SPEED / savox / futaba
Hpi Blitz/sc10 CASTLE CREATIONS.
Driving the best quality cars in the market.
808gx7r is offline   Reply With Quote
Old 03-25-2011, 04:39 AM   #3
Tech Addict
 
jammin32j's Avatar
 
Join Date: Feb 2008
Location: Lake county
Posts: 633
Default

Dumb question, but is your antenna up all the way on your transmitter? Also check and make sure your antenna on the receiver isn't damaged.
__________________
VP Pro, Agama
Hitec-7955's, 3Pk----AKA Racing Tires
Absolutehobbyz.com____Dirtrc.com
O'Donnell, D.I.R.T. R/C ultimate Tire Gluer
Jeremy Davis
jammin32j is offline   Reply With Quote
Old 03-25-2011, 04:12 PM   #4
Tech Adept
 
Join Date: Jan 2010
Posts: 109
Default

ok thanks guys but i have checked both of them, anything else?
marto1996 is offline   Reply With Quote
Old 03-25-2011, 05:12 PM   #5
Tech Regular
 
Led Finger's Avatar
 
Join Date: Oct 2010
Location: Cincinnati Ohio
Posts: 397
Trader Rating: 8 (100%+)
Default buggy woes

Id look at all your wires, Id had this happen to me before. Come to find out I had a servo wire that wore through ( stripped ) and grounded out on the chassis.. Everything was going nuts.. Just check your wires.
__________________
Mugen MBX6r USA - Mugen MBX6r ECO USA - RC8Te - Baja SS - B4.1 - Erevo Brushless
Led Finger is offline   Reply With Quote
Old 03-25-2011, 05:22 PM   #6
Moderator
 
J.Whiting's Avatar
 
Join Date: May 2005
Location: a very small town in wisconsin that is in the middle of absolutely no where
Posts: 4,536
Trader Rating: 57 (100%+)
Default

ok you have posted this question several times now.. this should be in the radio and electronics section just as i moved the rest of them... but to answer your questions..
you are using crystals= power lines,radio waves, and static will cause radio issues.. get a new radio and not 1 with crystyals... what radio are you using???
get a 2.4 radio this will have the least glitching issues..

also do you have the crystals the correct way?? the radio crystal in the radio and the reciever crystal in the reciever?? any bare wires??
__________________
Jeremy Whiting - serpent america - desoto racing - apicco race engines - RcRenew - jconcepts - Rc Pro Products - ko propo eurus - ko propo servos - VP PowerMaster Fuels - Answer-rc usa - advantage racing products - Parma/pse bodies - serpent 811 2.1 - 811t
J.Whiting is offline   Reply With Quote
Old 03-25-2011, 07:45 PM   #7
Tech Initiate
 
Gaskethead's Avatar
 
Join Date: Jan 2011
Location: Earth
Posts: 46
Default

Sory dont know what else could be the problem. but if you do get it fixed i suggest a fale safe so when ever it goes crazy on you it'll shut of automaticly.Good luck
Gaskethead is offline   Reply With Quote
Old 03-26-2011, 12:51 AM   #8
Tech Adept
 
Join Date: Jan 2010
Posts: 109
Default

ok thanks guys ill try all of these ideas
marto1996 is offline   Reply With Quote
Old 03-26-2011, 03:44 AM   #9
Tech Adept
 
Join Date: Jan 2010
Posts: 109
Default

Quote:
Originally Posted by J.Whiting View Post
ok you have posted this question several times now.. this should be in the radio and electronics section just as i moved the rest of them... but to answer your questions..
you are using crystals= power lines,radio waves, and static will cause radio issues.. get a new radio and not 1 with crystyals... what radio are you using???
get a 2.4 radio this will have the least glitching issues..

also do you have the crystals the correct way?? the radio crystal in the radio and the reciever crystal in the reciever?? any bare wires??
hey mate yeah im sorry i keep posting it here but i just needed some help, the guy at the hobby shop said check the wires and get a 2.4ghz radio aswell, also i have an lrp a2-stx?
marto1996 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Caster Racing Nitro Buggy Just Announced! hakmazter Nitro Off-Road 534 07-31-2010 06:20 PM
Help buying new 1/8th nitro buggy Jaap Nitro Off-Road 40 10-04-2009 12:44 AM
First buggy "Need Help" Centy Electric Off-Road 14 10-12-2006 07:24 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:30 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net