R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 02-26-2011, 08:08 AM   #1
Tech Apprentice
 
Join Date: Mar 2008
Posts: 55
Trader Rating: 2 (100%+)
Default Durango 410

So i bought some parts for my durango and worked on it last night and to my suprize i had bought one of the rear alum. insert i believe it was the left one. well the problem lies with the hole precut in the insert its to far to the right and does not match up with the 15mm screw that go's up through the bottom. Has any body seen these things bad from the company? Or do i have my Durango put together wrong? Please advise Thanks
mattythegreat is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Durango 410 mattythegreat Electric Off-Road 8 02-26-2011 09:49 AM
Your thoughts: durango 410 vs. Schu cat sx2 vs b44 vs. Kyosho lazer teeforb Electric Off-Road 18 01-01-2011 02:03 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:44 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net