R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 08-22-2010, 05:15 PM   #1
Tech Regular
 
Join Date: Oct 2009
Location: Dublin Ohio
Posts: 448
Trader Rating: 22 (100%+)
Default What plug for Novarossi Plus 21-5K?

Anyone know what plug works good for Novarossi Plus 21-5K? I'm using O'donnell 97T with Byron Race Gen2 30% fuel. Engine turns on but soon as taking off plug heater, they shut off. I have no idea on 8th buggy plug.
Thanks
__________________
Losi 8ight-T 2.0--RB WS7
Slash 4X4--Castle Sidewinder SCT
rcs950racer is offline   Reply With Quote
Old 08-23-2010, 02:12 AM   #2
Tech Master
 
Join Date: Dec 2008
Location: So Cal
Posts: 1,696
Default

If its the 5k then it takes standard plugs. If its the 5kt then it takes turbo plugs.
If its turbo the 97t is fine. Standard i would run a OD 77. If it flames when you pull the igniter off your plug is most likely bad. If you replace the plug and it continues to do the same then you are way too rich on bottom.
__________________
-TKO Competition Development-Sidewinder Fuel-
Alan D. is offline   Reply With Quote
Old 08-23-2010, 02:32 AM   #3
Tech Elite
 
merdith6's Avatar
 
Join Date: Oct 2009
Location: Brazoria, TX
Posts: 2,350
Trader Rating: 3 (100%+)
Default well

I had that happen once or twice in a turbo style Nova. Take the plug out, and remove the head button and clean it really good with a q tip and some denatured alcohol or whatever, especially down in the threads and in the taper area. "While you have the head off go ahead and clean the inside of the engine and carb." I would bet there is dirt in there, the head button, causing it to not seal...Put a new plug in it, 97t is perfect. and tighten the plug pretty good. Did you put an OS glowplug in it before? Sometimes that can distort the taper causing leaks, they don't really fit the Nova engines.....

Check the clutch too. the springs may be weakened or something that is hanging up....there is always a reason an engine won't run, and it can be irritating to find the cause sometimes....Be patient...and take it one step at a time......
__________________
Mad Dog drives a Mugen MBX-7, Novarossi engines, Clockwork Racing, Futaba radio, AKA/Proline Tires
merdith6 is offline   Reply With Quote
Old 08-23-2010, 07:29 AM   #4
Tech Elite
 
mblgjr's Avatar
 
Join Date: Sep 2006
Location: AL
Posts: 2,175
Trader Rating: 86 (100%+)
Default

Try the OD77t or Novarossi C6TGC, or C5TGC.

It should run on any of those.

Do NOT put an O.S. plug in it.
__________________
Team Associated Reedy JConcepts.net FusionX USA
mblgjr is offline   Reply With Quote
Old 08-23-2010, 01:24 PM   #5
Tech Prophet
 
houston's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2004
Location: portland OR
Posts: 15,088
Trader Rating: 91 (100%+)
Default

try to replace plug first , if you are good at tuning try to tune it in , if not find a good local engine tuner in your area to help you out .

the 21-5k was/is a great engine , loved it in truggy
__________________
TEAM FUSION X ENGINES / TEAM BYRON ORIGINALS / TEAM PROLINE RACING TIRES / TEAM SICK GRAPHICS /TEAM KYOSHO / things I support: COMP HEAT DEALER /TEAM LUNSFORD/ FUSIONX™ USA / TEAM KYOSHO / "H.E.S."™ / BYRON FUELS / RC-OMGUSA/KICWEBDESIGNZ/AKA TIRES/PROLINE RACING TIRES /RAYA RACING/BUKU POWER CLUTCH/M2CRACING/special thanks to STAV and JIM HOTTIGREENMOUNTAINGRILLS.COM
houston is offline   Reply With Quote
Old 08-23-2010, 02:11 PM   #6
Tech Regular
 
Join Date: Oct 2009
Location: Dublin Ohio
Posts: 448
Trader Rating: 22 (100%+)
Default

Quote:
Originally Posted by houston View Post
try to replace plug first , if you are good at tuning try to tune it in , if not find a good local engine tuner in your area to help you out .

the 21-5k was/is a great engine , loved it in truggy
I replace the plug to new 97T and still this happens. I got help from good local racer.
__________________
Losi 8ight-T 2.0--RB WS7
Slash 4X4--Castle Sidewinder SCT
rcs950racer is offline   Reply With Quote
Old 08-23-2010, 02:21 PM   #7
Tech Addict
 
cordarrow's Avatar
 
Join Date: Sep 2009
Posts: 542
Trader Rating: 17 (100%+)
Default

OK...with the glow plug igniter still attached to glow plug...how does it run?

Can you accelerate the motor?
cordarrow is offline   Reply With Quote
Old 08-23-2010, 02:28 PM   #8
Tech Regular
 
Join Date: Oct 2009
Location: Dublin Ohio
Posts: 448
Trader Rating: 22 (100%+)
Default

Quote:
Originally Posted by cordarrow View Post
OK...with the glow plug igniter still attached to glow plug...how does it run?

Can you accelerate the motor?
Yes but sometimes when I accelerate to max too fast, they shut off.
__________________
Losi 8ight-T 2.0--RB WS7
Slash 4X4--Castle Sidewinder SCT
rcs950racer is offline   Reply With Quote
Old 08-23-2010, 02:30 PM   #9
Tech Addict
 
cordarrow's Avatar
 
Join Date: Sep 2009
Posts: 542
Trader Rating: 17 (100%+)
Default

This is a good motor with good compression?
cordarrow is offline   Reply With Quote
Old 08-23-2010, 02:48 PM   #10
Tech Addict
 
cordarrow's Avatar
 
Join Date: Sep 2009
Posts: 542
Trader Rating: 17 (100%+)
Default

If it's in OK shape....and you can make it HERE
on Sunday....we'll sort you out.

Great bunch of guys...always willing to help.
cordarrow is offline   Reply With Quote
Old 08-23-2010, 04:38 PM   #11
Tech Regular
 
Join Date: Oct 2009
Location: Dublin Ohio
Posts: 448
Trader Rating: 22 (100%+)
Default

Well after heating up engine with hair dryer, engine wont stop when ever I pull off plug heater. I guess that was heating issue. Finally buggy runs without plug heater!
Thanks for helping me out guys.
__________________
Losi 8ight-T 2.0--RB WS7
Slash 4X4--Castle Sidewinder SCT
rcs950racer is offline   Reply With Quote
Old 08-23-2010, 05:40 PM   #12
Tech Adept
 
Join Date: Jan 2009
Location: wichita,ks
Posts: 176
Trader Rating: 6 (100%+)
Default

I run a OD100 plug 30% byrons and a msr1005 pipe header combo
jet flyer is offline   Reply With Quote
Old 08-23-2010, 08:52 PM   #13
Tech Prophet
 
houston's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2004
Location: portland OR
Posts: 15,088
Trader Rating: 91 (100%+)
Default

Quote:
Originally Posted by rcs950racer View Post
Well after heating up engine with hair dryer, engine wont stop when ever I pull off plug heater. I guess that was heating issue. Finally buggy runs without plug heater!
Thanks for helping me out guys.
so the engine is new?
__________________
TEAM FUSION X ENGINES / TEAM BYRON ORIGINALS / TEAM PROLINE RACING TIRES / TEAM SICK GRAPHICS /TEAM KYOSHO / things I support: COMP HEAT DEALER /TEAM LUNSFORD/ FUSIONX™ USA / TEAM KYOSHO / "H.E.S."™ / BYRON FUELS / RC-OMGUSA/KICWEBDESIGNZ/AKA TIRES/PROLINE RACING TIRES /RAYA RACING/BUKU POWER CLUTCH/M2CRACING/special thanks to STAV and JIM HOTTIGREENMOUNTAINGRILLS.COM
houston is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Novarossi .21 offroad Plus 4 dsl Offroad Nitro Engine Forum 3759 09-01-2014 05:30 PM
NovaRossi .21 Plus 21-5 review rczonecentral Nitro Off-Road 216 04-11-2009 09:35 PM
Glow Plug for Novarossi FMS franklucas Nitro Off-Road 9 03-08-2009 10:54 PM
Novarossi 367 cota348 Nitro Off-Road 48 08-21-2008 09:22 AM
Novarossi ,best choice? sac Nitro Off-Road 37 04-06-2008 09:35 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:10 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net