R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 07-07-2010, 04:29 AM   #1
Tech Initiate
 
Join Date: Apr 2009
Location: Blanchester
Posts: 36
Default Picco Evo 3 .21 Question

To be able to run 7min Qual. my engine runs around 290 deg. l have smoke coming out when running. Just need know what everyone else runs there engines. Its had probably a 3/4 of a gallon of fuel ran threw it. Thanks
losewheel is offline   Reply With Quote
Old 07-07-2010, 02:06 PM   #2
Tech Elite
 
mblgjr's Avatar
 
Join Date: Sep 2006
Location: AL
Posts: 2,175
Trader Rating: 86 (100%+)
Default

I've got one with about 3 gallons on it.

Runs 220F all day long on Byron's 25%

Check your shimming and what glow plug are you running?
__________________
Team Associated Reedy JConcepts.net FusionX USA
mblgjr is offline   Reply With Quote
Old 07-08-2010, 04:23 AM   #3
Tech Initiate
 
Join Date: Apr 2009
Location: Blanchester
Posts: 36
Default

Im using the Ofna #6 Medium plug and l havent done anything with the shim. The engine is running great im getting blue smoke coming out of the corners. But i think it is running way to hot. If i turn hsn back one hour it runs around 270 but cant finish the 7 min main
losewheel is offline   Reply With Quote
Old 07-08-2010, 04:26 AM   #4
Tech Champion
 
Maximo's Avatar
R/C Tech Elite Subscriber
 
Join Date: Jan 2005
Posts: 7,900
Trader Rating: 11 (100%+)
Default

what pipe is on it ?

you may have too many head shims...some of the EVO3 came with the head overshimmed...which will kill power and make the engine run hot....please remove your head and tell me how many shims it has....
Maximo is offline   Reply With Quote
Old 07-08-2010, 04:48 AM   #5
Tech Initiate
 
Join Date: Apr 2009
Location: Blanchester
Posts: 36
Default

Ok, l will take it off tonight and let you know the pipe i have is the ofna jammin jp-3 thanks
losewheel is offline   Reply With Quote
Old 07-08-2010, 06:40 AM   #6
Tech Elite
 
aussies1129's Avatar
 
Join Date: Jun 2007
Location: LAND DOWN UNDER
Posts: 3,485
Trader Rating: 74 (100%+)
Default

I had this engine with jp3 I used a 99 odonnell plug with standard head it ran around the 230-240 mark heaps of power and 10min run time always, piccos like to run on the rich side, as said in the previous post check your head shimming, I think I was around .2 or .3? and ran 25%, you can always strip it completley give it a good clean check everything out piston,sleeve check your bearings picco have been known to throw a bearing here and there, once back together use after run for start up lube, also check you fuel oil content use a well known brand, you can take your needle settings back to factory and tuneup from there.
goodluck they are a nice engine
__________________
Proudly supported by......
Premier Model Supplies Pty Ltd
H.E.I AUSTRALIA
XRAY*****PRO-LINE*****HUDY*****
-----FUTABA-----NOVAROSSI-----

Last edited by aussies1129; 07-09-2010 at 01:32 PM.
aussies1129 is offline   Reply With Quote
Old 07-09-2010, 04:02 AM   #7
Tech Initiate
 
Join Date: Apr 2009
Location: Blanchester
Posts: 36
Default

Ok, it has one shim in it and everything looked good in the engine. I had it running around 240 to 250 when we was running 5min Qual but when they switched to 7min i just turned it one hour and temp really jumped up and after the qual l check to see how much fuel l have left and there was just a little bit in the tank maybe just enough for one more lap.

Last edited by losewheel; 07-09-2010 at 04:22 AM.
losewheel is offline   Reply With Quote
Old 07-09-2010, 04:04 AM   #8
Tech Rookie
 
Join Date: Jul 2010
Posts: 1
Default dbx kyosho

i was wondering if there any up grades for a dbx kyosho 1/10 it running a gxr18
kyosho dbx aus is offline   Reply With Quote
Old 07-09-2010, 05:15 AM   #9
Tech Champion
 
Maximo's Avatar
R/C Tech Elite Subscriber
 
Join Date: Jan 2005
Posts: 7,900
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by losewheel View Post
Ok, it has one shim in it and everything looked good in the engine. I had it running around 240 to 250 when we was running 5min Qual but when they switched to 7min i just turned it one hour and temp really jumped up and after the qual l check to see how much fuel l have left and there was just a little bit in the tank maybe just enough for one more lap.

it has to have more then 1 shim....you needed to separate the shims.....
Maximo is offline   Reply With Quote
Old 07-09-2010, 05:37 AM   #10
Tech Initiate
 
Join Date: Apr 2009
Location: Blanchester
Posts: 36
Default

ok never checked to see if they was stuck together let you know in a little bit
losewheel is offline   Reply With Quote
Old 07-09-2010, 08:48 AM   #11
Tech Initiate
 
Join Date: Apr 2009
Location: Blanchester
Posts: 36
Default

ok, l cant get them apart but there is 2 shims
losewheel is offline   Reply With Quote
Old 07-12-2010, 12:58 PM   #12
Tech Initiate
 
Join Date: Apr 2009
Location: Blanchester
Posts: 36
Default

should i add another shim
losewheel is offline   Reply With Quote
Old 07-12-2010, 01:08 PM   #13
Tech Elite
 
mblgjr's Avatar
 
Join Date: Sep 2006
Location: AL
Posts: 2,175
Trader Rating: 86 (100%+)
Default

Quote:
Originally Posted by losewheel View Post
should i add another shim
Depends.

What is the thickness of each shim you have in your hand right now?
__________________
Team Associated Reedy JConcepts.net FusionX USA
mblgjr is offline   Reply With Quote
Old 07-13-2010, 04:16 AM   #14
Tech Initiate
 
Join Date: Apr 2009
Location: Blanchester
Posts: 36
Default

They are .1 mm
losewheel is offline   Reply With Quote
Old 07-13-2010, 07:36 AM   #15
Tech Champion
 
Maximo's Avatar
R/C Tech Elite Subscriber
 
Join Date: Jan 2005
Posts: 7,900
Trader Rating: 11 (100%+)
Default

does your engine have a shim under the sleeve ? some of the EVO 3 had shims under the sleeve
Maximo is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
JL EVO 3 "TUNED" Team Kamikaze Onroad Nitro Engine Zone 396 07-01-2014 09:03 PM
LIPO rating system. Time for xtreme rc to do a lipo shoot out. Joel Lagace Electric On-Road 152 08-07-2012 12:54 PM
Help me pick a engine for my Losi 8ight eagle_talon Nitro Off-Road 26 07-19-2008 05:36 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:32 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net