R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 06-22-2010, 04:07 PM   #1
Tech Rookie
 
Join Date: Jun 2009
Posts: 14
Default RC10GT2 engine temp?

Fired up my RC10Gt after it has been sitting for a while. Actually it sat for 5 years, then a few months ago I dusted it off, took the engine apart and gave it a good cleaning and got it running.

But then it sat for a few months

So today I start it up, and some fooling around with the body on, I check the temp with a Raytek gun, and it is almost 300. This with the stock engine that came in the RTR version. It is either an Associated or Tiger .15 engine.

It seemed to have a decent smoke trail.

I did notice bubbles in the fuel line. Tomorrow I am going to remove the fuel tank, clean and see if I can find any leaks. I read to submerge it under water and blow into it and see if bubbles come out.

I am also going to rezip the coupler on the exhaust pipe. heard if its loose there may not be enough pressure to the fuel tank?


Any other ideas?

Needles are at factory settings from when the engine was reassembled.
JuddGA is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
RC10GT2 thread!!!!!!! nitrosteve Nitro Off-Road 4464 08-20-2017 02:12 PM
wtb/wtt for hpi nitro mini any condition & new in box gt rc10gt2 asap 87fierogt R/C Items: Wanted to Buy 13 01-03-2010 02:09 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:35 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net