R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 01-12-2010, 07:09 PM   #1
Tech Initiate
 
Join Date: Apr 2009
Posts: 48
Default Xray 808 wheel hub bearing keep failing

The title prettymuch says it all.I will put a brand new set of outer wheel hub bearings in and be lucky to get 1 day of racing in before they begin to get gritty. I am trying to find a solution to this problem because the car handles great and I don't want to get rid of it. Iam running the plasting bearing carriers.
btownbasser is offline   Reply With Quote
Old 01-12-2010, 07:13 PM   #2
Tech Adept
 
Join Date: Mar 2009
Posts: 207
Trader Rating: 5 (100%+)
Default

try getting the bigger bearings and doing away with the plastic carriers. if that doesnt work it might be your actual hub. it might be tweaked just a bit. is it just one side or both rear wheel hubs?
quicklosi is offline   Reply With Quote
Old 01-12-2010, 07:15 PM   #3
Tech Initiate
 
Join Date: Apr 2009
Posts: 48
Default

it's front and rear.
btownbasser is offline   Reply With Quote
Old 01-12-2010, 08:22 PM   #4
Tech Apprentice
 
2tap's Avatar
 
Join Date: Dec 2009
Location: Denver Colorado
Posts: 90
Trader Rating: 3 (100%+)
Default

Perhaps an identical thread will solve the problem?
2tap is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xray 808 wheel hub bearing keep failing btownbasser Nitro Off-Road 12 01-13-2010 03:38 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:16 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net