R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 11-29-2009, 02:16 PM   #1
Tech Rookie
 
Join Date: Nov 2009
Posts: 7
Default plzzz help!

bro..my fukin car...its always something..i jst had it running fine 2 days ago..got super excited to go out and hit up the park today and the shit didnt start..my starter was getting it going but it just wouldnt start..the flywheel was spinning and it sounded like it was just about to start but it never did..what could be the issue to this? spark plug?
rippedfreak123 is offline   Reply With Quote
Old 11-29-2009, 02:17 PM   #2
Tech Elite
 
imaxx21's Avatar
 
Join Date: Nov 2007
Location: FL
Posts: 2,725
Trader Rating: 1 (100%+)
Send a message via AIM to imaxx21
Default

glow plug
__________________
-Crash
Upgrade RC www.upgrade-rc.com
imaxx21 is offline   Reply With Quote
Old 11-29-2009, 02:24 PM   #3
Tech Rookie
 
Join Date: Nov 2009
Posts: 7
Default

really think so?? it was just working fine though...how do i know if the glow plug is good or not?
rippedfreak123 is offline   Reply With Quote
Old 11-29-2009, 02:32 PM   #4
Tech Prophet
 
tc5 man's Avatar
 
Join Date: Oct 2007
Location: levittown pa
Posts: 16,873
Default

take the glow plug out with a 4 way wrech that has sockets around it make sure the inside of your cooling head is clean and just loosen it and take it out and stick the glow plug in the glow enigher and it should be bright red if it isnt than its bad also make sure you screw the glow plug in stright and tighten it dont overtighen it though,also what really helps is getting a glow enigher that has a meter on it
tc5 man is offline   Reply With Quote
Old 11-29-2009, 03:01 PM   #5
Tech Rookie
 
Join Date: Nov 2009
Posts: 7
Default

thanks guys..guess i'll just buy a new one so i dont have to go threw the trouble..hope thats the reason why
rippedfreak123 is offline   Reply With Quote
Old 11-29-2009, 03:46 PM   #6
Tech Addict
 
JBURCH's Avatar
 
Join Date: May 2008
Location: Hampton Va
Posts: 626
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by rippedfreak123 View Post
bro..my fukin car...its always something..i jst had it running fine 2 days ago..got super excited to go out and hit up the park today and the shit didnt start..my starter was getting it going but it just wouldnt start..the flywheel was spinning and it sounded like it was just about to start but it never did..what could be the issue to this? spark plug?
A bit of advice, posting with language like that will get the moderators to delete your thread, may even ban u.
JBURCH is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tamiya TA05 Touring Sedan kentech Electric On-Road 11403 06-21-2017 03:10 AM
Kuala Terengganu RC Track smilekt Malaysian R/C Racers 29327 03-12-2016 10:01 PM
RC equipments for Sale ijnek Malaysian R/C Racers 22836 09-09-2009 01:50 PM
New to this site.. need a little advice pageup Nitro Off-Road 33 02-12-2009 06:34 AM
the best setting for ex-1 mars r GT_CAPANG!! Radio and Electronics 9 08-28-2008 03:11 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:22 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net