R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 11-27-2009, 08:51 AM   #1
Tech Fanatic
 
Join Date: Sep 2008
Location: Rochester Mi
Posts: 859
Trader Rating: 4 (100%+)
Default 7955 problem

I was running my buggy today and all of a sudden my steering servo (7955)stopped responding. the servo just kept turning back and forth slowly. i tried a different battery and got the same result. i don't think it could be interference because i am using 2.4 and there was another guy at the track with 2.4 and he had no problems at all, i even asked for him to turn off his radio to see if by chance it was interference. i also doubt its a gear issue cause it was moving fine but on its own. anyone else ever have this happen?
fievel is offline   Reply With Quote
Old 11-27-2009, 08:57 AM   #2
Tech Addict
 
hdcruzer's Avatar
 
Join Date: Sep 2009
Location: Pittsburg Ca.
Posts: 732
Trader Rating: 12 (100%+)
Default

How old is the Servo? Sounds like its not centering. Hi tec is suppose to have good warranty service. Send it back and have them fix or replace.
__________________
Ofna Late Model-Losi 350-Losi RE 10-Hobbico CS170s
Coldfusion Fuel
Henchman Racing
hdcruzer is offline   Reply With Quote
Old 11-27-2009, 08:59 AM   #3
Tech Fanatic
 
Join Date: Sep 2008
Location: Rochester Mi
Posts: 859
Trader Rating: 4 (100%+)
Default

the servo is only about 6 months old at the most. i dont think i have the receipt anymore, can i still return it to them?
fievel is offline   Reply With Quote
Old 11-27-2009, 09:02 AM   #4
Tech Addict
 
Join Date: Feb 2009
Posts: 609
Trader Rating: 1 (100%+)
Default

Sounds like the servo is bad. They do have a good warranty so if you have your receipt you should be able to get a new one if it's not too old. If i remember correct it has a 3 year warranty. Good luck
romax is offline   Reply With Quote
Old 11-27-2009, 09:03 AM   #5
Tech Master
 
Join Date: Dec 2008
Location: So Cal
Posts: 1,696
Default

Send it in Hitec will take care of you.
__________________
-TKO Competition Development-Sidewinder Fuel-
Alan D. is offline   Reply With Quote
Old 11-27-2009, 09:18 AM   #6
Tech Lord
 
Frank L's Avatar
 
Join Date: Dec 2008
Location: NorCal
Posts: 12,499
Trader Rating: 148 (100%+)
Default

I agree just send it in with a letter explaining what's up and they will chck it out. I have only had 1 hitec servo go bad but they took care of it.
__________________
- X-Ray/ RC America Team Driver - MKS -
- XB8 - XB8T - XB8 E - OS Spec III - B2102 - 4PXR -
~ SSC ~ Godfather ~ Ironman ~ ButterySmooth ~
Frank L is offline   Reply With Quote
Old 11-27-2009, 09:26 AM   #7
Tech Master
 
OfnaJoe's Avatar
 
Join Date: Dec 2008
Location: Bristol Va
Posts: 1,570
Trader Rating: 58 (100%+)
Default

Just sent one of my 5955TG's in because it would just stop working while turning then start working again. They replaced the board and motor and it should be back to me today
Hitec warranty rules, go to there website and fill out and download the repair paper work and send it in, they have a 5 day turn around from the time they get it.
__________________
Mugen Seiki \\ Dialed RC \\ Tekin \\ SMC \\ AVID\\ AKA \\ Futaba
OfnaJoe is offline   Reply With Quote
Old 11-27-2009, 03:29 PM   #8
Tech Fanatic
 
Join Date: Sep 2008
Location: Rochester Mi
Posts: 859
Trader Rating: 4 (100%+)
Default

i took the servo apart and i can see some water on the circuit board. i am going to let in dry out and try it again.

I will contact hitec on Monday, I am not sure what they will be able to do for me because i no longer have the receipt and it now has water damage. hopefully it will be cheaper to fix then replace.
fievel is offline   Reply With Quote
Old 11-27-2009, 04:29 PM   #9
Tech Elite
 
imaxx21's Avatar
 
Join Date: Nov 2007
Location: FL
Posts: 2,725
Trader Rating: 1 (100%+)
Send a message via AIM to imaxx21
Default

shoulda just sent it in without opening it...you dont need a receipt
__________________
-Crash
Upgrade RC www.upgrade-rc.com
imaxx21 is offline   Reply With Quote
Old 11-28-2009, 03:22 PM   #10
Tech Fanatic
 
Join Date: Sep 2008
Location: Rochester Mi
Posts: 859
Trader Rating: 4 (100%+)
Default

i dried out the servo over night and it works fine now. hopefully all it was was a little water and now its going to be fine. ill try it out and see if it continues to work.
fievel is offline   Reply With Quote
Old 11-28-2009, 03:46 PM   #11
Tech Addict
 
Join Date: Feb 2009
Posts: 609
Trader Rating: 1 (100%+)
Default

Good , i wasn't sure about the receipt thing , good to know, i have one for throttle that has gone bad & don't have the receipt so i will be sending it in.
romax is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:12 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net