R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 11-15-2009, 02:21 PM   #1
Tech Elite
 
jonski's Avatar
 
Join Date: Aug 2001
Location: NW Indiana
Posts: 2,741
Trader Rating: 233 (99%+)
Default Hyperion Charger 0606i

Has anyone tried charging a gel cell battery with their Hyperion charger yet? I just got the charger and was messing around with some different batteries and got some weird information on the screen during the whole charge. I unplugged and replugged it a couple of times, but the stuff wouldn't go away.



It seemed like it charged ok, but do you think I should take the charger back?

Thanks,
Jon
jonski is offline   Reply With Quote
Old 11-15-2009, 02:36 PM   #2
Tech Elite
 
Zerodefect's Avatar
 
Join Date: Apr 2008
Location: Underground, Ohio
Posts: 4,305
Default

I'd take it back.

Best charger I've ever owned but I've never tried to charge lead-gel batteries with it. All my starter boxs a field batteries have been conveted to 4cell lipo.

The Bantum B6 is the same charger with slightly different programming, knew someone that blew up one of those charging a car battery.
Zerodefect is offline   Reply With Quote
Old 11-15-2009, 02:39 PM   #3
Tech Elite
 
smokinu's Avatar
 
Join Date: Apr 2008
Location: MODESTO CA
Posts: 4,863
Trader Rating: 60 (98%+)
Default

looks like the bottom line is the reading inside the batt. it just looks like its in another language to me. i dont think there is anything wrong

what other batts have you charged with it?
__________________
Marcus P.
\\Speedzone USA//Savox USA\\Caster Racing Parts//
www.speedzoneusa.com. www.casterracingparts.com
smokinu is offline   Reply With Quote
Old 11-15-2009, 02:47 PM   #4
Tech Lord
 
Frank L's Avatar
 
Join Date: Dec 2008
Location: NorCal
Posts: 12,499
Trader Rating: 148 (100%+)
Default

I have 2 of these 606i chargers one j bought over a year ago and one just a few months ago. The firmware is different in the new one it has a store mode on the lipo charge and it also has a pb 12v mode to charge lead acid batteries idk if the older charger has the pb mode. The firmware is upgradeable you need a special 20 buck cable butthen you can download the latest version from your computer. I haven't tried it yet but the cable is on order. As for your issue I would take it back or call te mfg and se what they say. These chargers operate like ottos computers and I think yours needs a reboot. Overall these chargers are some of the best I have owned.
__________________
- X-Ray/ RC America Team Driver - MKS -
- XB8 - XB8T - XB8 E - OS Spec III - B2102 - 4PXR -
~ SSC ~ Godfather ~ Ironman ~ ButterySmooth ~
Frank L is offline   Reply With Quote
Old 11-15-2009, 03:24 PM   #5
Tech Lord
 
Frank L's Avatar
 
Join Date: Dec 2008
Location: NorCal
Posts: 12,499
Trader Rating: 148 (100%+)
Default

Quote:
Originally Posted by jonski View Post
Has anyone tried charging a gel cell battery with their Hyperion charger yet? I just got the charger and was messing around with some different batteries and got some weird information on the screen during the whole charge. I unplugged and replugged it a couple of times, but the stuff wouldn't go away.



It seemed like it charged ok, but do you think I should take the charger back?

Thanks,
Jon
I just checked and both of my chargers have a pb charge mode that you can adj the amps and volts. Did you make sure to charge the gel battery on 12V?
__________________
- X-Ray/ RC America Team Driver - MKS -
- XB8 - XB8T - XB8 E - OS Spec III - B2102 - 4PXR -
~ SSC ~ Godfather ~ Ironman ~ ButterySmooth ~
Frank L is offline   Reply With Quote
Old 11-15-2009, 03:57 PM   #6
Tech Elite
 
Zerodefect's Avatar
 
Join Date: Apr 2008
Location: Underground, Ohio
Posts: 4,305
Default

He said he turned off the charger and plugged it back in and it was still like this.

Sure sighn that it needs reflashed, or the memory is bad. Alot of electronics with flash memory can spaz out and go into " egyption speak and spell mode". I've got a ton of switchgear that deos the same thing.

Deos this weird error go away? Or is it stuck there?
Zerodefect is offline   Reply With Quote
Old 11-16-2009, 06:10 AM   #7
Tech Lord
 
Frank L's Avatar
 
Join Date: Dec 2008
Location: NorCal
Posts: 12,499
Trader Rating: 148 (100%+)
Default

Ok danielson. Just a question.
__________________
- X-Ray/ RC America Team Driver - MKS -
- XB8 - XB8T - XB8 E - OS Spec III - B2102 - 4PXR -
~ SSC ~ Godfather ~ Ironman ~ ButterySmooth ~
Frank L is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hyperion Charger 2brothersracing Radio and Electronics 14 10-05-2009 02:52 AM
best charger for $150 ? bkdent Electric On-Road 40 01-28-2009 09:09 AM
Hyperion / Lipo / Novak / FT T4 TfnG R/C Items: For Sale/Trade 9 08-30-2008 12:47 PM
LiPo charger advice: Hyperion ac/dc vs. Orion avionics advantage jubilee Northwest Racers 19 03-11-2008 03:04 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:30 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net