R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 10-21-2009, 06:59 AM   #1
Tech Adept
 
Join Date: May 2009
Posts: 117
Trader Rating: 13 (100%+)
Default 8ight engine mount

ANyone have a problem with their 8ight one-pice not fittng well? I went to put it on my GRP yesterday and I really had to force it to get the pins in.
piranha21 is offline   Reply With Quote
Old 10-21-2009, 07:03 AM   #2
Tech Elite
 
lethalleigh29's Avatar
 
Join Date: Jan 2008
Location: At The Track
Posts: 2,687
Trader Rating: 13 (100%+)
Default

i have used mine for a long time and have had no problems and used several different engines.
lethalleigh29 is offline   Reply With Quote
Old 10-21-2009, 07:08 AM   #3
Tech Master
 
Garet Jax's Avatar
 
Join Date: Jun 2009
Location: Baltimore, MD
Posts: 1,332
Trader Rating: 91 (100%+)
Default

Quote:
Originally Posted by piranha21 View Post
ANyone have a problem with their 8ight one-pice not fittng well? I went to put it on my GRP yesterday and I really had to force it to get the pins in.
I have used mine too with no problems. Having said that if you tightened the screws on the engine before trying to attach it to the engine mount, then this is likely your problem.

Attach the engine mount arms to the engine, but do not tighten the screws fully. Then place the engine onto the engine mount tightening down the screws between the engine mount and the arms. Once those are tight, you can tighen the screws between the engine and the arms.

If you now remove the engine (and the arms) from the engine mount you will find it goes in much easier.

Once the gear meshing is done, sometimes the fit is a little tight, but nothing where you need to force anything.
__________________
I am not a "Tech Master" nor even close. I simply have a lot of posts. If you want some sage advice, the only that I can give is don't listen to me.
Garet Jax is offline   Reply With Quote
Old 10-21-2009, 07:47 AM   #4
Tech Adept
 
Join Date: May 2009
Posts: 117
Trader Rating: 13 (100%+)
Default

Yeah, the second time I tried I didn't tighten anything and it helped. I have heard of it lifting the flywheel a little higher...
piranha21 is offline   Reply With Quote
Old 10-21-2009, 05:20 PM   #5
Tech Elite
 
madweazl's Avatar
 
Join Date: Oct 2002
Location: Woodbridge, VA
Posts: 2,578
Trader Rating: 11 (100%+)
Default

Installed mine last week, fit was great and it popped right in. I snugged the motor and then tightened everything once it was sitting on the base.
__________________
RadioPost
Mugen MBX7r | CRE Picco 5TR/2120 | Hitec 7950/7940
Tekno NB48 | B6 Pro/2058 | Hitec 7950/7940
Kyosho RB6 | Viper VTX10r/Reedy Mach 3 9.5 | Hitec 7940
Schumacher SX3 Pro | Viper VTX10r/Reedy Mach 2 8.5 | Hitec 7940
madweazl is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
?? for ADAM DRAKE: GRP .21 Tuned Doesn't Fit Losi Quick Change Engine Mount thenetwerx Nitro Off-Road 19 07-10-2009 02:01 PM
Losi 2.0 8ight B/T - Losi Quick Change Engine Mount - BRAND NEW Trevor Williams R/C Items: For Sale/Trade 11 05-24-2009 12:14 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:15 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net