R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 09-26-2009, 07:23 PM   #1
Tech Rookie
 
Join Date: May 2009
Posts: 9
Exclamation rc10gt problem!

hello i have a rc10gt with a O.S .12 max cv-r engine and all the sudden today when i started it, it ran fine but after 2 mins of it running it started to bog down and went slower and slower when i try to accellarate till it stalls. any ideas.......i have tuned it low and high also tuned the idle and th.trim. please help!
HAGGARTY is offline   Reply With Quote
Old 09-26-2009, 07:30 PM   #2
Tech Master
 
Join Date: Jul 2007
Location: Rossville Ga
Posts: 1,398
Trader Rating: 10 (100%+)
Default

Soulds like it is losing pressure. Was it over heating? If so it probably is a pressure issue.
bigde2001 is offline   Reply With Quote
Old 09-26-2009, 07:38 PM   #3
Tech Rookie
 
Join Date: May 2009
Posts: 9
Default

Quote:
Originally Posted by bigde2001 View Post
Soulds like it is losing pressure. Was it over heating? If so it probably is a pressure issue.
ok how could i check the temp? and the engine gets hot real quick. how would i fix the pressure issue that and where is the pressure leaking out you think?

Last edited by HAGGARTY; 09-26-2009 at 07:54 PM.
HAGGARTY is offline   Reply With Quote
Old 09-27-2009, 07:25 AM   #4
Tech Adept
 
Join Date: Jul 2009
Location: Oneonta,AL
Posts: 139
Trader Rating: 9 (100%+)
Default

If it has been sitting up,it could be a bearing in the engine.All the cv-r's I've had don't last much more than a gallon,maybe 2 gallons if you run it easy and rich.I would suggest taking it out of the truck and checking for binding of the drivetrain,clutch,and engine.The engine should spin freely except on its compression stroke.Better yet,take the glow plug out and see how easy it turns over.
Dirtdobber is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
team assoc rc10gt planetary gear prob... whiteice217 Rookie Zone 12 05-17-2009 07:57 PM
RC10GT Stinger Exhaust Experience? Ducati-Rider Electric Off-Road 8 10-22-2004 04:33 PM
RC10gt too much bottom end Smooth Electric Off-Road 17 06-03-2004 10:03 PM


Tags
problem associated rc10gt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:40 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net