R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 09-08-2009, 10:04 AM   #1
Tech Elite
 
madweazl's Avatar
 
Join Date: Oct 2002
Location: Woodbridge, VA
Posts: 2,578
Trader Rating: 11 (100%+)
Default 8ight 2.0 RTR; couple questions.

Anyone noticing poor range? I'm loosing control at around 60 yards. I have considerably better range on my other cars; is this typical of the DX3S? Out of the box turns a lot sharper left than right. Still have to investigate that issue.
madweazl is offline   Reply With Quote
Old 09-08-2009, 10:07 AM   #2
Tech Regular
 
AndrewClaycomb's Avatar
 
Join Date: Aug 2009
Location: Wichita, KS
Posts: 340
Trader Rating: 10 (100%+)
Default

I've noticed telemetry not having the greatest range, but I haven't lost control yet. I only race, so I probably am not driving out as far as a basher would.
AndrewClaycomb is offline   Reply With Quote
Old 09-08-2009, 10:16 AM   #3
Tech Elite
 
madweazl's Avatar
 
Join Date: Oct 2002
Location: Woodbridge, VA
Posts: 2,578
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by AndrewClaycomb View Post
I've noticed telemetry not having the greatest range, but I haven't lost control yet. I only race, so I probably am not driving out as far as a basher would.
I usually dont run off track but I was running it up and down the street during break in. Telemetry range is terrible (~30').
madweazl is offline   Reply With Quote
Old 09-08-2009, 11:51 AM   #4
Tech Initiate
 
ReDnEcK25's Avatar
 
Join Date: Apr 2009
Location: Georgia
Posts: 40
Default

Yea the range on mine isnt good at all. and for the steering mine did the same thing all I did was messed around with the trim after that it would just fine.
ReDnEcK25 is offline   Reply With Quote
Old 09-08-2009, 11:54 AM   #5
Tech Elite
 
madweazl's Avatar
 
Join Date: Oct 2002
Location: Woodbridge, VA
Posts: 2,578
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by ReDnEcK25 View Post
Yea the range on mine isnt good at all. and for the steering mine did the same thing all I did was messed around with the trim after that it would just fine.
Got the steering issue fixed (radio setting); took a few minutes trying figure out how to toggle between left and right (guess I could have checked that manual thing...).
madweazl is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:44 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net