R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 08-31-2009, 08:25 PM   #16
TIX
Tech Master
 
TIX's Avatar
 
Join Date: May 2008
Location: Melbourne Australia
Posts: 1,943
Trader Rating: 17 (100%+)
Default

I've painted a few of the mugan bodies aswell and none of them have had a problem like this.
I use Parma FasColor paints and they have worked great
i use Isopropyl Alcohol to clean the bodies prior to painting so maybe try that
__________________
Alan Nankervis.

TIX Race Designs. Plaig Bearings. Thunder Innovations
TIX is offline   Reply With Quote
Old 08-31-2009, 08:55 PM   #17
Tech Apprentice
 
Join Date: Apr 2009
Posts: 59
Trader Rating: 3 (100%+)
Default

My body was painted with Tamiya PS paints... Maabe that is the issue then as I used Iridescent and backed it with black and I am getting hell of a lot of flaking...
Daniel.308 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:01 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net