R/C Tech Forums

R/C Tech Forums (http://www.rctech.net/forum/)
-   Nitro Off-Road (http://www.rctech.net/forum/nitro-off-road-130/)
-   -   Need help with engine please ( help please ) (http://www.rctech.net/forum/nitro-off-road/321574-need-help-engine-please-help-please.html)

Chewwie 08-21-2009 07:39 PM

Need help with engine please ( help please )
 
alright, i'm having problems with my idle, i can start the car but when i leave it idle for a little bit or even tap the brakes the truck dies. should i change all new tubing or that doesnt have anything to do with that ? why does it do that ? any info would be GREAT !!!!! i thought i was going to start off with a good weekend :cry:

imaxx21 08-21-2009 07:52 PM

is the idle set too low?

Chewwie 08-21-2009 08:08 PM

Quote:

Originally Posted by imaxx21 (Post 6238939)
is the idle set too low?

idle is right. and when i set the throttle trim , the truck still rolling and i can also drive it , should i reset the servo ?

imaxx21 08-21-2009 08:20 PM

are you saying you're using the throttle trim to set the idle stop?

if so, you need to set it on the carb itself, not the radio


what kind of truck is it?

Chewwie 08-21-2009 08:27 PM

Quote:

Originally Posted by imaxx21 (Post 6239021)
are you saying you're using the throttle trim to set the idle stop?

if so, you need to set it on the carb itself, not the radio


what kind of truck is it?

nono the trim is set.... the carb itself is set , but it rolls still and i can drive it, but when i brake the car dies for some reason , idle sounds a little weak too , hey thanks for helping me out

CONNARD 08-21-2009 08:40 PM

Chewwie, it's almost impossible to diagnose an egine problem on the internet but if I'm understanding you right, the truck rolls when it is at idle. If this is happening then it is one of three problems.
1 bad clutch bearings
2 a weak or broken clutch spring
3 a sticking clutch shoe ( this happens alot with alluminum shoes. just take them off and file a slight 45* angle on the outsides of the shoe. hope this helps.

xyzyx00 08-21-2009 08:46 PM

sounds to me like the idle speed screw is set too low and you have compensated for this with your radio trim (+) which makes your idle ok, but when you brake it pushes that slider back past your idle spot to where the needle is set (too small an idle opening) and it dies. you need to set your trim back to zero and turn that needle in until it idles. when you brake it shouldnt close that idle gap.

imaxx21 08-21-2009 08:46 PM

yeah what he said...

if you are certain that is good, check the clutch

if the clutch is good, then its prolly the engine tune

xyzyx00 08-21-2009 08:47 PM

Quote:

Originally Posted by CONNARD (Post 6239093)
Chewwie, it's almost impossible to diagnose an egine problem on the internet but if I'm understanding you right, the truck rolls when it is at idle. If this is happening then it is one of three problems.
1 bad clutch bearings
2 a weak or broken clutch spring
3 a sticking clutch shoe ( this happens alot with alluminum shoes. just take them off and file a slight 45* angle on the outsides of the shoe. hope this helps.

that could be too

Chewwie 08-21-2009 09:26 PM

Quote:

Originally Posted by imaxx21 (Post 6239122)
yeah what he said...

if you are certain that is good, check the clutch

if the clutch is good, then its prolly the engine tune

the truck is a HPI Firestorm

Chewwie 08-23-2009 12:41 AM

So , today i pulled out the motor from my hpi firestorm and took off the clutch bell , guess what the freakin clutch spring broke !!! what does that do anyways, i know it holds the clutch shoes. does it make the truck stall or cant hold idle ?

imaxx21 08-23-2009 12:42 AM

yeah a broken clutch shoe will make it stall and not idle

Chewwie 08-23-2009 01:20 AM

Quote:

Originally Posted by imaxx21 (Post 6242828)
yeah a broken clutch shoe will make it stall and not idle

the clutch shoe is fine , but the spring is not. so that will make the car stall or idle correctly ?

imaxx21 08-23-2009 01:23 AM

i meant spring


its dragging and causing the stall, just change them

Chewwie 08-23-2009 02:10 AM

Quote:

Originally Posted by imaxx21 (Post 6242935)
i meant spring


its dragging and causing the stall, just change them

sweet thanks for your help :nod: i'm just trying to get my brother going on the truck . parts on order !!! woot


All times are GMT -7. It is currently 04:42 PM.

Powered By: vBulletin v3.9.2.1
Content © 2001-2011 RCTech.net