R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 08-01-2009, 02:37 PM   #1
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default Igniter in: works, Igniter out: stals

I have a problem with my Kyoshio DBX. Since I flew to LA with it, when I have the igniter in, it works fine, starts and keeps RPM. When I take it out it stals instantly. plz help!
Nikzilla is offline   Reply With Quote
Old 08-01-2009, 02:41 PM   #2
Tech Adept
 
sickmojave's Avatar
 
Join Date: May 2009
Location: Mascotte, FL
Posts: 147
Trader Rating: 2 (100%+)
Default

Bad glow plug..
sickmojave is offline   Reply With Quote
Old 08-01-2009, 02:52 PM   #3
Tech Addict
 
Madbrad's Avatar
 
Join Date: Oct 2005
Posts: 727
Trader Rating: 29 (100%+)
Default

I agree with sickmojave on the plug, also could be really rich/lean. But go with the plug first before you start adjusting the carb.
__________________
XT8 - Werks B5
Hyper 10SC Novak PRO ESC 4.5HV
Madbrad is offline   Reply With Quote
Old 08-01-2009, 03:41 PM   #4
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default

Ok I will try switching glow plugs thx
Nikzilla is offline   Reply With Quote
Old 08-01-2009, 08:49 PM   #5
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default

new glow plug: still fail.

one new update:

If you raise the RPM and let the wheels spin freely and then take out the igniter, it won't stall untill you touch the gas again.

BTW, might the new fuel im using (same nitro % but this one is Traxas) be screwing this up?
Nikzilla is offline   Reply With Quote
Old 08-01-2009, 09:18 PM   #6
Tech Addict
 
RETRO RC's Avatar
 
Join Date: Jan 2007
Location: AUCKLAND NEW ZEALAND
Posts: 715
Default

Quote:
Originally Posted by Nikzilla View Post
new glow plug: still fail.

one new update:

If you raise the RPM and let the wheels spin freely and then take out the igniter, it won't stall untill you touch the gas again.

BTW, might the new fuel im using (same nitro % but this one is Traxas) be screwing this up?
yep a retune is definately on the cards
__________________
Agama A8 EVO 11 spec/ Argus A52 .21
Agama A8T / Argus A52 .23

offroaders get more jumps and like it rougher!
RETRO RC is offline   Reply With Quote
Old 08-01-2009, 09:54 PM   #7
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default

so what exactly should I be tunning? Idle? low? High? Which way?
Nikzilla is offline   Reply With Quote
Old 08-01-2009, 10:23 PM   #8
Tech Fanatic
 
Cory Kerber's Avatar
 
Join Date: May 2009
Location: Fresno, CA
Posts: 769
Trader Rating: 10 (100%+)
Default

You say it stalls when you give it gas, does it just cut off or bog out.
Cory Kerber is offline   Reply With Quote
Old 08-02-2009, 01:42 AM   #9
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default

it kinda does both. Sometimes (especialy first time starting after storage) it bogs out, other times it usially just cuts off
Nikzilla is offline   Reply With Quote
Old 08-02-2009, 11:50 AM   #10
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default

bump, please I need reaply in 20 minutes
Nikzilla is offline   Reply With Quote
Old 08-02-2009, 11:58 AM   #11
Tech Regular
 
jazjato's Avatar
 
Join Date: Jun 2008
Location: Erie, Pa
Posts: 255
Trader Rating: 3 (100%+)
Default

Go back to stock settings then tune from there. If unsure take a look at your exhaust while igniters on and its running. If your exhaust is wet then lean it out if little smoke richen it.
__________________
Team Terribles
jazjato is offline   Reply With Quote
Old 08-02-2009, 12:00 PM   #12
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default

ok, I will, btw, could temperature affect this? Cause LA is an oven right now.
Nikzilla is offline   Reply With Quote
Old 08-02-2009, 12:08 PM   #13
Tech Regular
 
jazjato's Avatar
 
Join Date: Jun 2008
Location: Erie, Pa
Posts: 255
Trader Rating: 3 (100%+)
Default

Weather temps will effect tune but an hour or so in either direction to keep engine temp in line. It should not cause you to flame the second you remove your ignitor.
__________________
Team Terribles
jazjato is offline   Reply With Quote
Old 08-02-2009, 12:24 PM   #14
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default

ok, I am going to the beach with my sister, Looks like I am going to have to tune there
Nikzilla is offline   Reply With Quote
Old 08-02-2009, 07:41 PM   #15
Tech Apprentice
 
Join Date: Jun 2009
Posts: 76
Default

I tuned it evry way possible and the issue was not resolved. After a while it even wouldn't start.
Nikzilla is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:52 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net