R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 07-12-2009, 04:04 PM   #16
Tech Lord
 
Frank L's Avatar
 
Join Date: Dec 2008
Location: NorCal
Posts: 12,500
Trader Rating: 148 (100%+)
Default

Looks like an 8ight to me. If you are using the right collet ( the short one) then are you using a quick change engine mount. If so make sure it's installed correctly.
__________________
- X-Ray/ RC America Team Driver - MKS -
- XB8 - XB8T - XB8 E - OS Spec III - B2102 - 4PXR -
~ SSC ~ Godfather ~ Ironman ~ ButterySmooth ~
Frank L is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
HPI R40 Nitro Car Forum EVOLUTION Nitro On-Road 11979 06-26-2012 07:57 PM
Kyosho V One RRR Evo doc56 Malaysian R/C Racers 2166 11-12-2009 02:30 AM
8ight 1.0 Stability Issues Chris__RC Nitro Off-Road 16 06-08-2009 08:51 PM
Nitro Motor Shimming for Pinion? Help everyjuangohome Nitro Off-Road 8 01-14-2009 12:11 PM
Heaver vs. Lighter Flywheel rmdhawaii Nitro On-Road 69 04-02-2007 11:22 PM
Any Tips for Jammin Mike.CL Electric Off-Road 13 03-15-2007 05:44 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:04 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net