R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 06-17-2009, 06:39 PM   #16
Tech Regular
 
slumlord's Avatar
 
Join Date: Jun 2008
Location: Peoria, AZ
Posts: 455
Trader Rating: 10 (100%+)
Default

Quote:
Originally Posted by Jaz240 View Post
I highly doubt you got a brand new novarossi engine with an air leak. I would think you have a bad tank, or a clogged carb, or one of your o-rings (manifold, Pipe) are torn and causing loss of pressure..Is there someone local who can help you?
He said his other nova (the p5) fired right up in the same vehicle. That's what made me think air leak. If he's blowing all the compression anywhere else except for the exhaust pipe he won't get the pressure he needs in the tank for the fuel to move up.
__________________
Jay Stuart #66
slumlord is offline   Reply With Quote
Old 06-17-2009, 06:46 PM   #17
Tech Lord
 
Jaz240's Avatar
R/C Tech Elite Subscriber
 
Join Date: Aug 2008
Location: Dwindle city
Posts: 12,492
Trader Rating: 52 (100%+)
Default

I think she's just too rich to start and he's not priming it enough. The fuel will flow back into the line if you stop priming it and his Fuel nipple is above his fuel line, especially if he has stopped priming before the fuel got into the engine..

Shane the fuel needs to enter the engine, not just the carb for your engine to fire.

Different engines= different plugs..make sure the plug is good! My Nova needed to be leaned about 2 hours to start it, it was so rich..Try to find an experienced racer to help so you dont ruin your new engine

PS Like the new Avatar Jay
__________________
nothing to see here................................
Jaz240 is offline   Reply With Quote
Old 06-17-2009, 07:00 PM   #18
Tech Regular
 
slumlord's Avatar
 
Join Date: Jun 2008
Location: Peoria, AZ
Posts: 455
Trader Rating: 10 (100%+)
Default

Quote:
Originally Posted by Jaz240 View Post

PS Like the new Avatar Jay
Love the squidbillies! Darrin turned me on to them, watch season 1 and 2 at the Vegas race.
__________________
Jay Stuart #66
slumlord is offline   Reply With Quote
Old 06-17-2009, 07:15 PM   #19
Tech Apprentice
 
Join Date: Mar 2009
Location: Whistler, BC
Posts: 62
Trader Rating: 15 (100%+)
Default Had the same problem

I got a new n21 limited a couple weeks ago. I had the same problem of getting fuel into the engine and to fire after I pre-heated it.

I thought I had a tank or fuel line issue at first. But, do believe I got a bit of heat on the carb from the heat gun. I could hear the fuel sizzling as it entered the carb when I primed it, and I had a lot of air in the fuel line. I heated it to 200-210. But only a small amount gets past the LSN so it does not have to get that hot in relation to the rest of the motor.

I only heated the motor to about 180 and that seemed to make the problem go away. Now its broke in and runs great and starts up easy when cold starting.
Kirbdog is offline   Reply With Quote
Old 06-17-2009, 07:34 PM   #20
Tech Addict
 
Join Date: Oct 2008
Location: Foley, Al
Posts: 516
Trader Rating: 1 (100%+)
Default

when I broke in this same engine it took alot of patience. it was very tight even after pre-heating and took some tuning to even get it going but after a couple of times it got easier. I have over 2 gallons on it now and still have to heat it up or it gives my ofna truggy box a fit. Be patient, lean it out some, heat it at the head make sure your box battery is super charged. It wont be easy but it can be done.
__________________
Making a comeback !!
roadracer43 is offline   Reply With Quote
Old 06-17-2009, 08:43 PM   #21
Tech Regular
 
Join Date: May 2009
Location: Mississippi
Posts: 299
Trader Rating: 4 (67%+)
Default

Thanks for everyones help! I went ahead and replaced the fuel tank and there it was! Started right up. I guess a few weeks back when my tank popped loose and the clutch bell wore onto it. Finally blew out I guess, still can't see a hole but the engine starts up fine and that's what I wanted!
__________________
Hot Bodies D8-future home of a novarossi plus 4(courtesy of H.E.S.and Monty)-DS1015-spektrum dx3r/Team Terribles
Shane369 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Novarossi engines thread EVOLUTION Onroad Nitro Engine Zone 5360 08-14-2017 11:48 PM
The Nitro Pit Dbackmasta Arizona-New Mexico Racing 18732 09-13-2012 08:27 AM
new engine woes (novarossi rs12) packetdreamer Nitro On-Road 39 08-07-2004 09:14 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:21 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net