R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 05-23-2009, 11:15 AM   #16
Tech Master
 
jhipps835's Avatar
 
Join Date: Apr 2009
Location: Chicago, IL
Posts: 1,071
Trader Rating: 13 (88%+)
Default

Dang. Well i have servos laying around. But the gear isnt metal its plastic. So im guessing the servo i have laying around wont be very good. right?
__________________
Losi 8ight 2.0 - O.S V-Spec - Futaba - AKA - M8 - Spektrum - Byrons 20%
jhipps835 is offline   Reply With Quote
Old 05-23-2009, 11:22 AM   #17
Tech Regular
 
jgtruggy's Avatar
 
Join Date: Nov 2007
Location: Portland,OR
Posts: 450
Default

RIGHT,

Send back that servo and explain what is going on. Most likely they'll send you a new one or replace parts for cheap. JR sent me a new one without reciept even. Good luck
__________________
Losi SCTE
Tekin RX8/Tekin Pro-4 4000kv
Topgearhobbies.com
jgtruggy is offline   Reply With Quote
Old 05-23-2009, 11:22 AM   #18
Tech Fanatic
 
Join Date: Jan 2009
Location: Connecticut
Posts: 775
Trader Rating: 4 (100%+)
Default

Should be fine for throttle.
__________________
LRP Z.28R - 3
Spur Gear - 0
howtowakeakar is offline   Reply With Quote
Old 05-23-2009, 11:36 AM   #19
Tech Master
 
jhipps835's Avatar
 
Join Date: Apr 2009
Location: Chicago, IL
Posts: 1,071
Trader Rating: 13 (88%+)
Default

ok. Well the futaba servo i have on throttle is metal gear so im goin to put that in the steering and a differrent servo in for throttle. While i wait for the Hitec servo to get back.
__________________
Losi 8ight 2.0 - O.S V-Spec - Futaba - AKA - M8 - Spektrum - Byrons 20%
jhipps835 is offline   Reply With Quote
Old 05-23-2009, 12:14 PM   #20
Tech Lord
 
Jaz240's Avatar
R/C Tech Elite Subscriber
 
Join Date: Aug 2008
Location: Dwindle city
Posts: 12,492
Trader Rating: 52 (100%+)
Default

It only looked to me like the Servo horn was stripped out. I saw the screw moving but the horn was not..You may also have the wrong servo horn on..They dont all fit all servo's..Go get a live person to help you..This is not an internet solvable problem

It is also possible that the bushing on the top case is worn, or fell out..
__________________
nothing to see here................................
Jaz240 is offline   Reply With Quote
Old 05-23-2009, 12:22 PM   #21
Tech Master
 
jhipps835's Avatar
 
Join Date: Apr 2009
Location: Chicago, IL
Posts: 1,071
Trader Rating: 13 (88%+)
Default

Yea. I dont think the servo horn im using is right for the servo. I took off the original servo horn that came with the servo but it had a ball at the end where the steering arm was supposed to snap on. But thats not how my truggy is. So i guess i need a new servo arm
__________________
Losi 8ight 2.0 - O.S V-Spec - Futaba - AKA - M8 - Spektrum - Byrons 20%
jhipps835 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
SAVAGE - SS, .25, .21 Official Thread! Horatio Monster Trucks 11167 05-15-2017 08:40 PM
CRC Battle Axe, GenXPro 10, 1/10th pan, Brushless, Lipo,4c, Road, Oval,TipsandTricks John Stranahan Electric On-Road 1776 03-01-2016 12:18 PM
8T 2.0 polarismaster Nitro Off-Road 15880 02-02-2015 10:31 AM
Serpent 950R Arno Nitro On-Road 193 06-02-2009 03:42 PM
Please Help Muah! Speedjunkyz Nitro On-Road 36 09-05-2008 07:13 AM
Power Capacitor to gain acceleration BigBear Electric On-Road 208 02-22-2007 01:25 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:44 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net