R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 08-01-2009, 07:42 PM   #106
Tech Adept
 
Join Date: Feb 2009
Location: virginia
Posts: 156
Default

Quote:
Originally Posted by Saber186 View Post
Damn that sure made it one expensive pizza..lol
ive done a few in here, mainly not connecting throttle linkageafter motor remount only to have it start and go wide open in front of everyone!

my most recent would be similar to your radio incident, my son gets into my rc stuff from time to time.he's 2. anyhow i get to the local track to get some track time which is an hour away only to pull out my dx3r and look down to see no antenna, nothin but a ripped in half wire i guess you can figure what happened...

well atleast horizon fixed it for free minus shipping but i went on and got me a spek radio case.
__________________
rc-pro racing in gloucester va/TEAM TERRIBLES
ST-RR/8ight 2.0
osspeed,ebmods pipe,trinity platinum 30%,dx3r
crawldad91 is offline   Reply With Quote
Old 08-02-2009, 04:41 AM   #107
Tech Regular
 
Join Date: Jul 2009
Location: Perth, West Australia
Posts: 451
Trader Rating: 19 (100%+)
Default

Just today... i'm still breaking in my hyper 7... my brother and I were out at the park doing some laps... pull the car in to check temp... my brother get's the temp gauge... checks temp... and it came back at 196 !!!!! After I had my heart attack... look closer and it was in Fahrenheit, not Celcius like I had set it to.

PS: i'm australian.. so metric is the way down here !!!
LordAnubis is offline   Reply With Quote
Old 08-05-2009, 05:24 PM   #108
Tech Adept
 
Join Date: Jan 2006
Location: Lebanon Missouri
Posts: 206
Trader Rating: 2 (100%+)
Default

bump
Saber186 is offline   Reply With Quote
Old 08-05-2009, 05:59 PM   #109
Tech Master
 
megasaxon's Avatar
 
Join Date: Jul 2004
Location: Lake City, PA
Posts: 1,715
Trader Rating: 25 (88%+)
Send a message via AIM to megasaxon Send a message via Yahoo to megasaxon
Default

Quote:
Originally Posted by LordAnubis View Post
Just today... i'm still breaking in my hyper 7... my brother and I were out at the park doing some laps... pull the car in to check temp... my brother get's the temp gauge... checks temp... and it came back at 196 !!!!! After I had my heart attack... look closer and it was in Fahrenheit, not Celcius like I had set it to.

PS: i'm australian.. so metric is the way down here !!!
wow that would blow my mind, 196 C is like a million degrees in Fahrenheit lol
__________________
Team Associated RC10GT
Team Associated RC10GT2
megasaxon is offline   Reply With Quote
Old 08-11-2009, 08:34 PM   #110
Tech Adept
 
Join Date: Jan 2006
Location: Lebanon Missouri
Posts: 206
Trader Rating: 2 (100%+)
Default

not really a duh but a dammit.....throttle servo glitched right as it went out and caused my buggy to sorta surge...I hit the wall at the end of the straight and tore up my Steering servo....so now I need to replace BOTH servos and of course this weekend is the Missouri State nitro series race
Saber186 is offline   Reply With Quote
Old 09-19-2009, 03:16 PM   #111
Tech Adept
 
Join Date: Jan 2006
Location: Lebanon Missouri
Posts: 206
Trader Rating: 2 (100%+)
Default

just a lil bump
Saber186 is offline   Reply With Quote
Old 09-19-2009, 06:30 PM   #112
Tech Addict
 
maxair45's Avatar
 
Join Date: Jul 2008
Posts: 702
Trader Rating: 18 (95%+)
Default

-Trying to thread a ball end on a turnbuckle my first time, not knowing that one side threads in the opposite direction....
-Going to start my main in my 2wd electric stadium truck without the battery strap on it....another time with the battery strap on but without a battery....
-Sitting there yelling at my sc10 because the body won't go on it, turns out it was my slash body.
-Putting the rear shocks on the front and the front shocks on the rear of my xxxt......thats why it handled for shit

I'm sure i'm forgetting some
__________________
Sponsor:
Rcbros.com
maxair45 is offline   Reply With Quote
Old 06-30-2010, 08:39 AM   #113
Tech Elite
 
Join Date: Mar 2009
Posts: 3,657
Trader Rating: 5 (100%+)
Default

i fired up my engine with none of the back plate screws on

I was like "what the hell is that funny noise"? I kept trying to start it like a big dummy cause i was in a hurry to practice before my qual. When i looked down to see what the damn rattling noise was (sounded like a REALLY bad bearing), the backplate was moving in and out really really fast.

The piston skirt has a nice indention to it now as a reminder. At least it didn't break.
__________________
"You are not understanding the fundamental principles of my fragmented personality"

Mugen
dreaux is offline   Reply With Quote
Old 06-30-2010, 08:42 AM   #114
Tech Master
 
jbright33's Avatar
 
Join Date: Dec 2008
Location: shamokin pa
Posts: 1,348
Trader Rating: 14 (100%+)
Send a message via AIM to jbright33
Default

put stickers on a body with protective film still over it....
__________________
JESSE BRIGHT
jbright33 is offline   Reply With Quote
Old 06-30-2010, 08:43 AM   #115
Tech Elite
 
Dlewis4's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2010
Location: Saint Joseph, MO
Posts: 4,758
Trader Rating: 148 (100%+)
Default

MY first big race with my truggy... i pulled the block out to clean the chassis, threw it back in quickly to get it ready for the main.

Fired it up... without the servo horn on... on the pit lane wall. Blew the engine. Lol.
__________________
Why is this hobby so full of drama? Its toy cars....
Dlewis4 is offline   Reply With Quote
Old 06-30-2010, 08:46 AM   #116
Tech Elite
 
Join Date: Mar 2009
Posts: 3,657
Trader Rating: 5 (100%+)
Default

then today a couple days after my last race. Went to take the cooling head off and noticed i was missing a screw.

what the hell was wrong with me that day? ran fine anyway till i broke a clutch spring at the first lap of my main
__________________
"You are not understanding the fundamental principles of my fragmented personality"

Mugen
dreaux is offline   Reply With Quote
Old 06-30-2010, 08:58 AM   #117
Tech Regular
 
secretsg's Avatar
 
Join Date: Mar 2006
Posts: 470
Trader Rating: 7 (100%+)
Default

I remember thinking they forgot to pack the body in the kit. (Long time ago with my first Lexan body RC.)
secretsg is offline   Reply With Quote
Old 06-30-2010, 09:36 AM   #118
Tech Addict
 
salvaticustomjs's Avatar
 
Join Date: Dec 2009
Location: Davie, FL
Posts: 647
Trader Rating: 76 (100%+)
Default

Once I was marshalling for a Novice class and I got stuck marshalling the area by a big double. A car flipped over in between the doubles and I had to run and get it. I checked to make sure nothing was coming, didn't see anything so I bent over and had a T4 land on my back with the throttle pegged... Had a huge bruise and two tire tracks down my back! Wish I had a video of that...
salvaticustomjs is offline   Reply With Quote
Old 06-30-2010, 10:17 AM   #119
Tech Champion
 
Jason Pelletier's Avatar
 
Join Date: Jul 2007
Location: New York
Posts: 8,820
Trader Rating: 33 (100%+)
Default

Bought a Werks B5
__________________
Island Raceway & Hobby
Jason Pelletier is offline   Reply With Quote
Old 06-30-2010, 10:19 AM   #120
Tech Champion
 
JAMMINKRAZY's Avatar
 
Join Date: Jun 2007
Location: Pittsburgh PA
Posts: 6,575
Trader Rating: 17 (100%+)
Default

Quote:
Originally Posted by RB FIVE View Post
Bought a Werks B5
Hahahahahahaha. LOL. Still with the B5. Priceless!

Hey are you going to the cash race at LCRC next weekend?
__________________
-Koby Kubrin-
Thanks to my Sponsors:
Serpent America | Team Novarossi | Desoto Racing | Race AKA | Ridgeway Bodies
JAMMINKRAZY is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:32 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net