R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 04-16-2009, 09:24 AM   #1
Tech Regular
 
ICBeloitRacer's Avatar
 
Join Date: Apr 2009
Location: Nashville, TN
Posts: 307
Trader Rating: 7 (100%+)
Default Omega X3 Air Leak

I have a Hot Bodies Lightning 2 Evo on the way with an Omega X3 engine that I plan on racing this summer. The previous owner mentioned that the engine had a minor air leak that affected the idle, causing the engine to idle high and cut out after about 10 seconds. He said the issue arose after he'd handled the engine for clutch maintenance, and that he hadn't dropped the engine or anything like that. I'm just wondering what might cause an issue like that, and if it would be a relatively easy fix. I have some nitro engine experience, but I haven't wrenched on one in a few years. I'd really appreciate the help and advice.

Thanks!
__________________
"Next time he shows up, kick him in the Balls!! You should be able to win then."
TLR 22 2.0 MM/Trackstar II 120A/LRP 10.5/Turnigy/Airtronics/AKA
BSR BT-4 USGT/Trackstar 80A 21.5/Turnigy/Airtronics/RIDE
TLR 8ight-E 3.0/Trackstar/Hobbystar 1450 kV/Turnigy/Airtronics/AKA
ICBeloitRacer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:27 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net