R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 04-12-2009, 08:20 AM   #1
Tech Initiate
 
Join Date: Apr 2009
Posts: 31
Default having trouble tunning my savage x 4.6 help needed

I have been having trouble keeping my savage x 4.6 tuned. I was driving my savage yesterday and it was running great I could barely keep the frount wheels on the ground. I cheacked the temp. it was running at 220 exatly. Then I made a few more passes and then with out warning it started running like crap. After that I could not get it to run right. It had a bad lag in the throtle from idle to wide open and also ran week. i have only ran 7-8 tanks the truck is new. Please help.
esp6606 is offline   Reply With Quote
Old 04-12-2009, 09:13 AM   #2
Tech Addict
 
cweb's Avatar
 
Join Date: Jan 2006
Location: DelCo
Posts: 562
Trader Rating: 35 (100%+)
Default

Check your glow plug. If your tune went out that fast, that could be the problem. If you have a hand lense(small magnifying glass) look at the plug coil. if the coil is broken or disstorted then you are way to lean. put in a new plug and run your savage like you normaly do. after that tank take out the plug and look at it, if it's shinny and wet then you are rich and on the safe side. if it is grey in the first tank or two you are close to an ideal tune, but also close to beeing lean. keep glow plugs handy because they do wear out pretty fast depending on the fuel you use and the quality of the plug also.
__________________
Team Whiteknuckle- CW

B5M- viper-rc/Hitec/avid/schelle/mip/protek-rc/lunsford
T5m- viper-rc/Hitec/avid/schelle/protek-rc/lunsford
cweb is offline   Reply With Quote
Old 04-12-2009, 11:42 AM   #3
Tech Initiate
 
Join Date: Apr 2009
Posts: 31
Default thanks

thanks for the advise
esp6606 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
having trouble tunning my savage x 4.6 help needed esp6606 Monster Trucks 13 04-15-2009 06:39 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:53 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net