R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 04-08-2009, 10:02 PM   #1
Tech Rookie
 
Join Date: Apr 2009
Posts: 12
Default Engine Dies at high RPM

So I just got my 2.5 Sportmaxx running again today and everything seems fine except for when the engine trys to hit high RPM.

Half throttle and everything is fine but when you try and really open it up the car just shuts off.

I've tried setting the highspeed needle 4 turns out and then adjusting it from there but nothings worked.

New glow plug and everything, new fuel lines, cleaned the engine.

What could it be?!
H4CK3D4L1F3 is offline   Reply With Quote
Old 04-08-2009, 11:17 PM   #2
Tech Elite
 
imaxx21's Avatar
 
Join Date: Nov 2007
Location: FL
Posts: 2,725
Trader Rating: 1 (100%+)
Send a message via AIM to imaxx21
Default

richen up the high speed needle
__________________
-Crash
Upgrade RC www.upgrade-rc.com
imaxx21 is offline   Reply With Quote
Old 04-08-2009, 11:45 PM   #3
Tech Elite
 
tkhoo's Avatar
 
Join Date: Jun 2003
Location: Somewhere in Penang Island, Malaysia
Posts: 3,495
Trader Rating: 45 (98%+)
Send a message via MSN to tkhoo
Default

TS already mention he richen 4 turns out and retune but still same.
__________________
1/8 scale buggy: HB D8, Truggy: 1/12 Jammin CRT.5
Radio: Sanwa M8 power by Sanyo Eneloop, Charger: Hot Power 6016
http://pgrcclub.blogspot.com/
tkhoo is offline   Reply With Quote
Old 04-08-2009, 11:49 PM   #4
Tech Regular
 
tristyn's Avatar
 
Join Date: Dec 2008
Location: CRESCENT CITY CA. NORTHERN TIP OF CALIFORNIA
Posts: 396
Trader Rating: 4 (100%+)
Default

does the engine still have good compression
tristyn is offline   Reply With Quote
Old 04-08-2009, 11:58 PM   #5
Tech Champion
 
asw7576's Avatar
 
Join Date: Sep 2004
Posts: 5,792
Default

Quote:
Originally Posted by H4CK3D4L1F3 View Post
So I just got my 2.5 Sportmaxx running again today and everything seems fine except for when the engine trys to hit high RPM.

Half throttle and everything is fine but when you try and really open it up the car just shuts off.

I've tried setting the highspeed needle 4 turns out and then adjusting it from there but nothings worked.

New glow plug and everything, new fuel lines, cleaned the engine.

What could it be?!
Do you still some smoke at that point ?

If you see smoke at that point, that means the engine is still rich....... turn clockwise the high speed needle ( clockwise = to lean ) by half turn and see what happen. If the idle rpm become too high, turn the idle rpm needle anti clockwise .

Continue to lean the needle by 10 minutes increments until the engine sounds crispy enough when you accelerate to top speed. The best clue when to stop if you have a temp gun, and stop at around 95C to 105C ( coz some kit standard engine don't like high temp ).

Good luck.
__________________
On Road : Xray NT1 , RX8 , T4 || Mugen Seiki MRX4-R , MTX4 , MTX3 prospec || Tamiya M03 , M04 || Top Racing Sabre FD2
Off Road : Xray XT8 || Hobao Hyper 8
Radio : Futaba 3PKS || KO propo EX-10 eurus
asw7576 is offline   Reply With Quote
Old 04-09-2009, 03:49 AM   #6
Tech Elite
 
joe of loath's Avatar
 
Join Date: Mar 2007
Location: Bristol, England, United Kingdom
Posts: 4,857
Trader Rating: 1 (100%+)
Default

My old HPI G3.0 engine did this, and it was because it had no pinch left, and at low RPM it had compression, but at high RPM the fuel/air mix was being squashed out of the cylinder, so it died about 3/4 throttle. I had it repinched, but sold it so don't know how it goes now.
__________________
HPI E-Firestorm - Tamiya TA05 racer (carbon chassis, 10.5 brushless etc) - LRP Blast S10 BX - Revo 2.5r truggy conversion (in progress)
joe of loath is offline   Reply With Quote
Old 04-09-2009, 05:05 AM   #7
Tech Initiate
 
Join Date: Feb 2009
Location: Dubai, UAE
Posts: 22
Default

Before you run your engine, try rotating the flywheel and see if it's fairly easy to turn over or if there's noticeable compression left....if little or no compression then that could probably be your problem. If you're not sure, then try after the engine is run and up to temp, shut her down and see if there's any compression.

Or try the HSN as previously mentioned. Sometimes if it's lean it shuts off at full throttle.

How hot does your engine get? do you have sufficient cooling holes? Overheating shuts the engine down too.
RockinRo is offline   Reply With Quote
Old 04-09-2009, 06:23 AM   #8
Tech Rookie
 
Join Date: Apr 2009
Posts: 12
Default

So if it was bad compression how would i fix it? A new head gasket?
H4CK3D4L1F3 is offline   Reply With Quote
Old 04-09-2009, 06:53 AM   #9
Tech Champion
 
Trevor Williams's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2009
Location: Illinois
Posts: 8,218
Trader Rating: 195 (100%+)
Default

Quote:
Originally Posted by H4CK3D4L1F3 View Post
So if it was bad compression how would i fix it? A new head gasket?
you would need to purchase a new piston/sleeveset to be back to optimum specs.......You could always half a$$ it and just get a sleeve pinch done as well

Does'nt Traxxas have an exchange program for their engines?
__________________
RC10-B6d | RC10-B64d
SmacTrac
#WeAreAE #ReedyPower #AE4Life
Trevor Williams is offline   Reply With Quote
Old 04-09-2009, 07:17 AM   #10
Tech Rookie
 
Join Date: Apr 2009
Posts: 12
Default

How would bad compression cause the motor to run fine at lower rpm but then Completly die at high rpm?
H4CK3D4L1F3 is offline   Reply With Quote
Old 04-09-2009, 08:49 AM   #11
Tech Rookie
 
Join Date: Apr 2009
Posts: 12
Default

Quote:
Originally Posted by joe of loath View Post
My old HPI G3.0 engine did this, and it was because it had no pinch left, and at low RPM it had compression, but at high RPM the fuel/air mix was being squashed out of the cylinder, so it died about 3/4 throttle. I had it repinched, but sold it so don't know how it goes now.
Sorry if it's a noob question but what's "pinch"
H4CK3D4L1F3 is offline   Reply With Quote
Old 04-09-2009, 09:04 AM   #12
Tech Master
 
KThatcher's Avatar
 
Join Date: Aug 2007
Location: 1000 Oaks, Ca.
Posts: 1,845
Trader Rating: 64 (100%+)
Default

Also check your clutch bell bearings.. if those are bad your engine wont run right..
__________________
- Picco - Triton RC - 818 Designs - Team-CRP - RCRenew.com -
Pro Motion T-shirts -
KThatcher is offline   Reply With Quote
Old 04-09-2009, 09:10 AM   #13
Tech Rookie
 
Join Date: Apr 2009
Posts: 12
Default

Okay so with a little searching i found out what pinch is and it sounds pretty plausible. Do i have to take it in somewhere to get it pinched or is this something i can do at home?

Another thing, could flame out be a possibility? It's a new glow plug but i was thinking it could maybe be faulty.
H4CK3D4L1F3 is offline   Reply With Quote
Old 04-09-2009, 09:13 AM   #14
Tech Initiate
R/C Tech Elite Subscriber
 
Join Date: Feb 2009
Posts: 44
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by H4CK3D4L1F3 View Post
How would bad compression cause the motor to run fine at lower rpm but then Completly die at high rpm?
At lower RPMs the engine has more time to charge and discharge the cylinder and it is under less demand. At higher RPM the leakage by the piston is too great and creates a premature exhaust port. In a multi cylinder engine this would be indicated by a skip or dead miss in the powerband.
Jasonguy is offline   Reply With Quote
Old 04-09-2009, 09:19 AM   #15
Tech Rookie
 
Join Date: Apr 2009
Posts: 12
Default

Another thing is, is that it happens at the same rpm everytime. It's very very consistant. There's no variation when it dies.

Im not sure if this is relevant or not. im just throwing it out there.
H4CK3D4L1F3 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
"the tuning bible" houston Onroad Nitro Engine Zone 311 04-24-2017 11:18 PM
Team Orion CRF Wasp Rev X-Dyno results Nano Onroad Nitro Engine Zone 1531 11-07-2010 01:43 AM
Yay Dvx400Rider Nitro Off-Road 7 02-27-2009 08:25 PM
Please Help Muah! Speedjunkyz Nitro On-Road 36 09-05-2008 07:13 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:18 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net