R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 04-07-2009, 09:43 PM   #1
Tech Regular
 
Join Date: Mar 2007
Location: Bono,AR
Posts: 307
Trader Rating: 2 (100%+)
Default O'Donnell temp gun ??

I have a o'donnell temp gun and the battery went dead in it and I put a new one in it and all it does now is flash a "C" and says hold on it and that is all i can get it to do . Is there away to reset it and how can I do it ?
eflite300 is offline   Reply With Quote
Old 04-07-2009, 10:33 PM   #2
Tech Master
 
Join Date: Feb 2007
Location: pasadena, CA
Posts: 1,487
Trader Rating: 11 (100%+)
Default

try pulling the battery out and put it back in and see what it does
__________________
go really fast and turn left....
Robert.Hull is offline   Reply With Quote
Old 04-07-2009, 10:52 PM   #3
Tech Regular
 
Join Date: Mar 2007
Location: Bono,AR
Posts: 307
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by Robert.Hull View Post
try pulling the battery out and put it back in and see what it does
I have done that many time and still the same thing
eflite300 is offline   Reply With Quote
Old 04-07-2009, 11:36 PM   #4
Tech Master
 
Join Date: Feb 2007
Location: pasadena, CA
Posts: 1,487
Trader Rating: 11 (100%+)
Default

mmmm did you put the correct battery in?
__________________
go really fast and turn left....
Robert.Hull is offline   Reply With Quote
Old 04-08-2009, 05:21 AM   #5
Tech Regular
 
Join Date: Mar 2007
Location: Bono,AR
Posts: 307
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by Robert.Hull View Post
mmmm did you put the correct battery in?
yes the battery is in there the right way
eflite300 is offline   Reply With Quote
Old 04-08-2009, 06:07 AM   #6
Tech Regular
 
Purdue Engineer's Avatar
 
Join Date: Oct 2008
Posts: 407
Trader Rating: 8 (100%+)
Default

I have the same one, and it's doing the same thing. I used it one time for breakin now nothing. I put a new battery in it and now it dosn't even turn on. I got nothing. I was going to call a-main and see if they will take it back, but I bought it about 2 mounths ago, but only used it once. Do you thing they will still let me return it or should I call O'Donnell. Some one please help, I need it for my next race.
Purdue Engineer is offline   Reply With Quote
Old 04-08-2009, 07:33 AM   #7
Tech Lord
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,482
Trader Rating: 8 (100%+)
Send a message via MSN to Integra
Default

CALL the # on the package....Send it back if they even ask for it....and get an HPI one....they Will do it......i went through about 3-4 of the OD guns before i got one that worked alright....but eventually that one took a Sh*t as well....so i called and they send me a HPI one which i was reluctant to use at first...but honestly its a real nice piece and that battery actually lasts.
__________________
TNS Driver - Radio Post - Blue Groove Apparel - Team Panther - Hitec - Losi - W.E.D. Paint - Clockwork Fuel - Competition Heat - SUMO Racing - Tekin - Team Terribles - M2C Racing - Matrix Concepts - Kal Gard - BuKu Power - DE Racing -
Integra is offline   Reply With Quote
Old 04-08-2009, 08:04 AM   #8
Tech Master
 
Join Date: Feb 2007
Location: pasadena, CA
Posts: 1,487
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by eflite300 View Post
yes the battery is in there the right way
no,did you use the correct battery?
__________________
go really fast and turn left....
Robert.Hull is offline   Reply With Quote
Old 04-08-2009, 08:38 AM   #9
Tech Apprentice
 
Gumball's Avatar
 
Join Date: Feb 2009
Location: El Monte, CA
Posts: 55
Default

O'D was the first Temp Gun i ever purchased! $35 back in 2007!!!! and got to use it for about a month. then the temp reading went waaaaaaay off. changed battery.... same thing happened! never got a +/_ 1 accurate reading! always compared with my biddy's temp gun, O'D was off about 40 something degrees! WTF is that???? swapped batteries... same thing! most expensive worthless thing I ever bought!
__________________
I Drive.... (or try to drive LOL!)
KYOSHO INFERNO ST-RR w/ BCE K7-RR | EB-Mods EXTECH .24 | TRINITY BIG BOY PIPE | J Concept FUTABA | ACE SERVOs | AKA | BYRON's GEN 2 30% | RB S7 (back up) | Intellect LiPo | KHZ
and
KYOSHO INFERNO GT (GymKhana RC - Project)
Gumball is offline   Reply With Quote
Old 04-08-2009, 03:24 PM   #10
Tech Regular
 
Join Date: Mar 2007
Location: Bono,AR
Posts: 307
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by Robert.Hull View Post
no,did you use the correct battery?
yes it is the same kind that was in it
eflite300 is offline   Reply With Quote
Old 04-08-2009, 03:40 PM   #11
Tech Addict
 
JBURCH's Avatar
 
Join Date: May 2008
Location: Hampton Va
Posts: 626
Trader Rating: 2 (100%+)
Default

Mine did the same thing, piece of chit in my opinion. So I said the heck with it and spent the dough for an EXergen gun and have not been dissapointed yet going on 2 years with it
JBURCH is offline   Reply With Quote
Old 04-08-2009, 03:42 PM   #12
Tech Master
 
Shark413's Avatar
 
Join Date: Apr 2007
Location: SoCal
Posts: 1,554
Trader Rating: 24 (100%+)
Default

Don't know if this helps but here is a link to the manual. Sounds like you already tried everything they mentioned in the manual.

http://manuals.hobbico.com/odo/odop9000-manual.pdf
__________________
AE B5M - Tekno SCT410 - Kyosho SC6, SCR & RB6 - HB D413
SCVRC - Santa Clarita Valley RC & HotRod Hobbies
Shark413 is offline   Reply With Quote
Old 04-08-2009, 05:01 PM   #13
Tech Regular
 
HulkNT1's Avatar
 
Join Date: Sep 2007
Posts: 390
Trader Rating: 1 (100%+)
Default

why is this temp gun sooo freaking expensive:? EXergen gun
HulkNT1 is offline   Reply With Quote
Old 04-08-2009, 05:09 PM   #14
Tech Regular
 
HulkNT1's Avatar
 
Join Date: Sep 2007
Posts: 390
Trader Rating: 1 (100%+)
Default

Who has use the Losi screw drive / temp gun??? is it any good??
HulkNT1 is offline   Reply With Quote
Old 04-21-2009, 02:46 PM   #15
Tech Regular
 
Join Date: Mar 2007
Location: Bono,AR
Posts: 307
Trader Rating: 2 (100%+)
Default

Just wanted to say O'Donnell got me fixed up on the gun there a good company to work with
eflite300 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Temp guns - Basic questions noR Offroad Nitro Engine Forum 19 01-27-2013 07:25 PM
Racers!!... Best temp gun? eziduzit Nitro Off-Road 62 08-06-2008 02:04 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:10 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net