R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 03-31-2009, 10:50 AM   #1
Tech Master
 
mikesd1980's Avatar
 
Join Date: Mar 2009
Location: NE, Pa
Posts: 1,281
Trader Rating: 66 (100%+)
Default GRP .21 or Extech .24

I have a GRP .21 in my truggy that I have about 15 tanks through. It will not stay running while on the ground. When I start on the starter box it runs fine. It shuts off even while I am giving it gas like its not getting fuel. It very rich now. Any Ideas.

I have a Ex-tech .24 that I brought to replace the GRP .21. I am thinking about putting the grp in my buggy. I have a grp non-tuned in my buggy now.

Any help on tuning the grp will help. And should I put the ex-tech in my truggy. I have all losi's.
mikesd1980 is offline   Reply With Quote
Old 03-31-2009, 12:05 PM   #2
Tech Regular
 
Join Date: Jan 2009
Location: Northern MN
Posts: 295
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by mikesd1980 View Post
I have a GRP .21 in my truggy that I have about 15 tanks through. It will not stay running while on the ground. When I start on the starter box it runs fine. It shuts off even while I am giving it gas like its not getting fuel. It very rich now. Any Ideas.

I have a Ex-tech .24 that I brought to replace the GRP .21. I am thinking about putting the grp in my buggy. I have a grp non-tuned in my buggy now.

Any help on tuning the grp will help. And should I put the ex-tech in my truggy. I have all losi's.
Sounds very rich. Will it idle? Even on the ground? Maybe you should lean the HSN a couple of hours and try it again. What plug, pipe and fuel are you running?
John Schafer is offline   Reply With Quote
Old 03-31-2009, 12:08 PM   #3
Tech Master
 
Join Date: Dec 2008
Location: So Cal
Posts: 1,696
Default

Make sure your clutch is in good working order and not dragging. If it runs in the starter box then dies when it touches ground then your clutch could be dragging or your clutch bell bearings could be shot.
__________________
-TKO Competition Development-Sidewinder Fuel-
Alan D. is offline   Reply With Quote
Old 03-31-2009, 01:38 PM   #4
Tech Elite
 
Join Date: Jun 2006
Location: Omaha,NE
Posts: 2,548
Trader Rating: 85 (99%+)
Default

Quote:
Originally Posted by Alan D. View Post
Make sure your clutch is in good working order and not dragging. If it runs in the starter box then dies when it touches ground then your clutch could be dragging or your clutch bell bearings could be shot.

What he said, that's the first thing that came to mind when you stated it dies when placed on the ground. I would check the clutch and go back to stock settings and go from there. As far as the extech .24 you won't be dissapointed should you put it in the truggy it's got way more grunt in a truggy than the GRP would with excellent run times for a .24.
WideOpenThrottle RC is offline   Reply With Quote
Old 04-01-2009, 04:42 AM   #5
Tech Master
 
mikesd1980's Avatar
 
Join Date: Mar 2009
Location: NE, Pa
Posts: 1,281
Trader Rating: 66 (100%+)
Default

Quote:
Originally Posted by John Schafer View Post
Sounds very rich. Will it idle? Even on the ground? Maybe you should lean the HSN a couple of hours and try it again. What plug, pipe and fuel are you running?
I am running the 2053 that came in the promo kit. I have a OS p3 plug in it. I ran it yesterday for about 30 min. I turned the idle up alittle and ran fine. I rich the HSN a little because the temp got to 250.
mikesd1980 is offline   Reply With Quote
Old 04-01-2009, 05:39 AM   #6
Tech Master
 
mikesd1980's Avatar
 
Join Date: Mar 2009
Location: NE, Pa
Posts: 1,281
Trader Rating: 66 (100%+)
Default

Quote:
Originally Posted by Alan D. View Post
Make sure your clutch is in good working order and not dragging. If it runs in the starter box then dies when it touches ground then your clutch could be dragging or your clutch bell bearings could be shot.
The clutch is ofna 13t with lst aluminum shoes with sportwerks flywheel. Everything is new and it have no drag. I checked that when I first was having the problem.

All is fine now. Thanks for the help.
mikesd1980 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
JAMMIN X2 CRT!!!! luis carballo Nitro Off-Road 1009 02-07-2015 02:53 PM
GRP... Engine... Thread... xlgraphicspro Offroad Nitro Engine Forum 2135 09-10-2013 08:46 AM
Trinity EXTECH .21 Fierle03 Offroad Nitro Engine Forum 2130 06-09-2011 07:01 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:52 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net