R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 03-17-2009, 01:29 AM   #16
Tech Regular
 
Join Date: Mar 2008
Posts: 330
Trader Rating: 4 (100%+)
Default

i heard about this heating up problem on the fut. receiver 2 mons. ago but i wanted the best radio so i decide to get the fut 3pks 2.4 ghz,so far so good
mbx5rcr34 is offline   Reply With Quote
Old 03-17-2009, 01:41 AM   #17
Tech Apprentice
 
Join Date: Jan 2009
Posts: 75
Default

the problem i know is only for 603ff and 630fs receiver

the new 604 (4pk receiver) and the new 603fs DIVERSITY i think dont have the problem

PS i use futaba bls351 and a 3vcs + faast with lrp regulator and lrp lipo.

but i make hole in the receiver box of the mp9
amonmp9 is offline   Reply With Quote
Old 03-17-2009, 07:42 AM   #18
Tech Master
 
Bigedmond's Avatar
 
Join Date: Jul 2005
Posts: 1,837
Trader Rating: 18 (100%+)
Default

I had an issue with mine this past summer. I was running an HT lipo with there regulator. During the summer, i stopped using the lipo all together and the issue stopped. 3 weeks ago, i went to straight lipo with no regulator. No problems yet, but it isnt in the 100s yet.
Bigedmond is offline   Reply With Quote
Old 03-17-2009, 07:50 AM   #19
Tech Master
 
JoeyTheRocket's Avatar
 
Join Date: Sep 2008
Location: New Albany, Ohio
Posts: 1,893
Trader Rating: 11 (100%+)
Send a message via AIM to JoeyTheRocket Send a message via Yahoo to JoeyTheRocket
Default

You have to send them in to Futaba and ask for the "new chip". I have had 4 receivers from them and all of them had the over heating problem. One of the team drivers told me about the issues and told me just to send them in. I have sent mINE in and received the new ones with no problems.

PS. The 4pk is what I use and thats what I have had the issues with. Infact I had to send the Radio in at one point too because it would clear out models on its own.
__________________
Joey Kubat ↔ MWNS Staff www.MidwestNitro.com
Mugen Seiki / AKA Racing / Novarossi / PT RC Racing Oils / Advantage Racing Products

Last edited by JoeyTheRocket; 03-17-2009 at 08:00 AM.
JoeyTheRocket is offline   Reply With Quote
Old 03-17-2009, 07:55 AM   #20
Tech Adept
 
Join Date: Mar 2008
Posts: 114
Trader Rating: 1 (100%+)
Default

I had the same problem last year. It caused like 4 dnf's so i switched over to spektrum. I contacted Futaba and they were of no help at all. it's a shame you have to spend near $400 to have problems with no help from the factory.
__________________
www.powerhousercperformance.com

www.coldfusionrcproducts.com

Last edited by Fierle03; 03-17-2009 at 08:54 AM.
Fierle03 is offline   Reply With Quote
Old 03-17-2009, 08:52 AM   #21
Tech Adept
 
what_stanger?'s Avatar
 
Join Date: Mar 2009
Location: Northern IL
Posts: 138
Trader Rating: 8 (100%+)
Send a message via AIM to what_stanger?
Default

Just send them in for warranty work? Has anyone noticed the newer receivers have blue on them instead of orange? I was wondering if maybe orange were the overheating ones and blue are the 'new' ones.
what_stanger? is offline   Reply With Quote
Old 03-17-2009, 09:00 AM   #22
Tech Elite
 
rcjunky10's Avatar
 
Join Date: Feb 2007
Location: Fuquay Varina, NC
Posts: 2,160
Trader Rating: 217 (100%+)
Default

Quote:
Originally Posted by Integra View Post
so the Faast Rx will take strait lipo no question's asked ?
Mist467 - I had the same issue with my FASST system so to the auction block she went as Futaba, at that time, seemed to be aware of the issue but unwilling to offer a remedy.


Integra - The RX is not necessarily the problem with running unregulated 7.4v power, it's everything down stream from there. Servos, PT...they are not rated to take 7.4v, which is actually a bit higher when it first comes off the charger.

I've read posts from guys that run unregulated, in IMHO it's a crap shoot. You may get away with it 9/10 times, but it's the 10th time that comes back to bite you in the ass and your $$$ electronics. At that point you'll wish that you'd installed a regulator. Just my .02!
rcjunky10 is offline   Reply With Quote
Old 03-17-2009, 09:56 AM   #23
Tech Regular
 
soccerlaw's Avatar
 
Join Date: Jan 2008
Posts: 434
Trader Rating: 24 (100%+)
Default

I've been thinking of running straight lipo (no regulator) with my 4pk 604 receivers. Plugged in a lipo direct over the weekend to set end points etc and about 15 minutes of having it plugged in, the receiver seemed waaaaay too warm. Didn't affect performance, but definitely rethinking now. Not too worried about anything downstream as I know my servos can handle it.
soccerlaw is offline   Reply With Quote
Old 03-17-2009, 01:30 PM   #24
Tech Lord
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,482
Trader Rating: 8 (100%+)
Send a message via MSN to Integra
Default

Im Fully aware of that rcjunky10...i just like to keep a tally of how many guys i know that run unregulated...and i have yett to even hear a horror story of servo's or Rx's blowing up or failing because of it...and IF something were to happen....a couple 100 in servo's and receiver's is just a better excuse to upgrade to the lipo rated stuff thats coming out as of late.
__________________
TNS Driver - Radio Post - Blue Groove Apparel - Team Panther - Hitec - Losi - W.E.D. Paint - Clockwork Fuel - Competition Heat - SUMO Racing - Tekin - Team Terribles - M2C Racing - Matrix Concepts - Kal Gard - BuKu Power - DE Racing -
Integra is offline   Reply With Quote
Old 03-17-2009, 02:50 PM   #25
Tech Addict
 
Join Date: Jan 2009
Posts: 711
Trader Rating: 27 (100%+)
Default

well i called futaba again today and still no help...i still dont understand why they act like its the first time they have ever heard about it??...he was like "wow really its the first time we have ever heard about it"...what bs...i can pull up maybe 50 post of people with the same problem...and thats just the surface guys...anyone want a 3pk???...so sad to think i have spend so much money with them and they dont want to help...i have 4 bls servos i have bought over the last month...and the 3pk also...thats pretty much over a grand in a month and they said basically sorry cant help u...i love the servos but so disapointed with them im getting rid of all my futaba stuff...spektrum and hitec i come running back to u...F*&% futaba...
mist467 is offline   Reply With Quote
Old 03-17-2009, 04:06 PM   #26
Tech Regular
 
tallyram's Avatar
 
Join Date: Aug 2007
Posts: 476
Trader Rating: 11 (100%+)
Default

i also run lipo in the Tx and for the Rx(with a 7v regulator). i would think that the receiver would still fit when turned on its side, might have to move things around a bit inside the box though. i run my 3pks and fasst in an xray xt8 and an associated rc8, just for reference!
tallyram is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:24 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net