R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 02-12-2009, 10:23 PM   #1
Tech Rookie
 
Join Date: Feb 2009
Posts: 4
Default Need help with my Losi Aftershock

I have a team losi aftershock, its been sitting for about a year after goin through the 5 tank breakin cycle, last time i drove it on the 5th tank, it want crazy on me, and crashed and flipped but didnt break anything, so i pulled it out today its been about a year like i said, but i took it to the hobby shop so i could get it tuned in, and the guy got it tuned, we took it out side to drive it and the thing wont go, it will move about 2 inches when you give it throttle, and then you let off and it dies. what could be the problem??
dan27218 is offline   Reply With Quote
Old 02-12-2009, 10:31 PM   #2
TIX
Tech Master
 
TIX's Avatar
 
Join Date: May 2008
Location: Melbourne Australia
Posts: 1,943
Trader Rating: 17 (100%+)
Default

check that the clutch isnt worn down to far after break in. i think they had the composite shoes in them and they wear down pretty quick.

we had one doing the same thing the other day. it would idle fine but as soon as you put it down it wouldnt go anywhere and would die. we pulled the clutch off and there was nothing left of the shoes
__________________
Alan Nankervis.

TIX Race Designs. Plaig Bearings. Thunder Innovations
TIX is offline   Reply With Quote
Old 02-12-2009, 10:37 PM   #3
Tech Champion
 
JAMMINKRAZY's Avatar
 
Join Date: Jun 2007
Location: Pittsburgh PA
Posts: 6,575
Trader Rating: 17 (100%+)
Default

Quote:
Originally Posted by TIX View Post
check that the clutch isnt worn down to far after break in. i think they had the composite shoes in them and they wear down pretty quick.

we had one doing the same thing the other day. it would idle fine but as soon as you put it down it wouldnt go anywhere and would die. we pulled the clutch off and there was nothing left of the shoes
+1 definately check your clutch. That is most likely the problem. If you have to put new shoes in get some aluminum ones. Those composite shoes won't last on such a big heavy truck. I'm not sure if the dynamite max life shoes will fit that clutch(don't see why they wouldn't) but they would be a good bet.
__________________
-Koby Kubrin-
Thanks to my Sponsors:
Serpent America | Team Novarossi | Desoto Racing | Race AKA | Ridgeway Bodies
JAMMINKRAZY is offline   Reply With Quote
Old 02-12-2009, 10:43 PM   #4
Tech Rookie
 
Join Date: Feb 2009
Posts: 4
Default

cool i took it apart and the shoes dont look to worn(is there any certain spec?), with the engine off of the chassis should the gear closest to the transmisson housing be able to spin freely?, oh and the clutch bellhousing has changed colors from the silver to a copper and blue from the heat is that normal, just looked at the engine and the knuckles of the shoes are about flush with the springs.
dan27218 is offline   Reply With Quote
Old 02-13-2009, 05:49 AM   #5
Tech Rookie
 
Join Date: Feb 2009
Posts: 4
Default

anybody else have any ideas?
dan27218 is offline   Reply With Quote
Old 02-13-2009, 06:35 AM   #6
Tech Regular
 
slumlord's Avatar
 
Join Date: Jun 2008
Location: Peoria, AZ
Posts: 455
Trader Rating: 10 (100%+)
Default

Too rich? Also, when pulling the throttle, give it quick bumps that way the engine doesn't load up on you and flame.
__________________
Jay Stuart #66
slumlord is offline   Reply With Quote
Old 02-13-2009, 06:45 AM   #7
Tech Master
 
Chill_Will's Avatar
 
Join Date: Sep 2007
Location: Flo-Town, N.W. Alabama
Posts: 1,431
Trader Rating: 32 (100%+)
Default

The After Shock is known to have tranny problems in my area. When you took the engine off did it roll? Sounds like drivetrain problems to me. You said it sat up for a year so check the bearings. One might be locked up from sitting so long.
__________________
A-Train racing (Woooooo Wooooo!!)
Chill_Will is offline   Reply With Quote
Old 02-13-2009, 07:00 AM   #8
Tech Elite
 
Join Date: Mar 2008
Location: Erie Pa.
Posts: 3,323
Trader Rating: 19 (100%+)
Default

I dont think any gears should be able to spin freely. The clutch bell on there is a 2 speed that means it looks like 2 different gears in 1. They both should be both meshed properly with the 2 spurgears. And the Dynamite max life shoes are good and the LST 2 stock clutch shoes are a good for the aftershock and they last for ever too.
__________________
TT MT4G3 all tricked
TTST4G3 MT4ed out

JR servos Hitec servos. Gens ace lipos KO radio.
malik is offline   Reply With Quote
Old 02-13-2009, 07:15 AM   #9
Tech Rookie
 
Join Date: Feb 2009
Posts: 4
Default

the gear that spins freely is the gear closest to the transmisson, the other when you spin it, the whole truck move so im guessing its just for the other gear, im gonna try replacing the clutch shoe and the bell housing
dan27218 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
$$$ Person to make the 50K post wins $25.00 $$$ racer1812 Chat Lounge 51794 08-15-2017 08:21 AM
buy a brand new losi aftershock or buy a used traxxas revo? xxx-ntad2 racer Monster Trucks 7 06-18-2007 07:19 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:35 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net