R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 02-11-2009, 11:19 AM   #1
Tech Rookie
 
Join Date: May 2006
Posts: 8
Default Ofna Ultra Comp2 Engine issues

So i found a Ofna Ultra Comp2 the other day in the trash(im a garbageman). Brought it home and cleaned it up. I completely ripped the engine apart and cleaned it. I put it all back together and i cannot seem to get it to start.

The pull start was broke when i found it so ive been trying to start it with a start box that i found in the trash(love my job btw) previously.

I got another nitro truck so i know how to start an engine but this one wont go. Glow plug is bright orange hot. I turned the engine by hand till i got fuel in the line. Then a few more times to get fuel in the carb. Nothing. I think i see why they threw this thing away.

Now i have read that these Force engines are complete pieces of crap. This is the Force .26 btw.

What do you guys suggest? Just buy a new engine? if so, can you direct me towards a good replacement. Will my old pipe(assuming its the stock pipe) fit? Not going to be racing. Just bashing.

or should i keep messing with this one?
Tfizzle is offline   Reply With Quote
Old 02-11-2009, 11:29 AM   #2
Tech Addict
 
Madbrad's Avatar
 
Join Date: Oct 2005
Posts: 727
Trader Rating: 29 (100%+)
Default

You should set the HSN and LSN back to factory settings and start there. Not sure what they are but im sure with google you can find them.

Your exhuast pipe will work with another motor as long as its in the .21-.28 range.

How much do you want to spend on the new motor? The mach427 can be had pretty cheap $125 or so off ebay, a lot of people like those. Might be a little too much power for a buggy but just make sure you buy a new motor. Other wise you might end up in the same spot.
Madbrad is offline   Reply With Quote
Old 02-12-2009, 02:06 PM   #3
Tech Rookie
 
Join Date: May 2006
Posts: 8
Default

The Team Losi Mach 427?

or

Dynamite Mach 427?

See them both. Or are the same engine?
Tfizzle is offline   Reply With Quote
Old 02-12-2009, 03:20 PM   #4
Tech Rookie
 
Join Date: May 2006
Posts: 8
Default

Or any other suggestions? Not looking to spend a whole lot. Maybe max $150
Tfizzle is offline   Reply With Quote
Old 02-12-2009, 03:37 PM   #5
Tech Lord
 
Jaz240's Avatar
R/C Tech Elite Subscriber
 
Join Date: Aug 2008
Location: Dwindle city
Posts: 12,492
Trader Rating: 52 (100%+)
Default

Hyper .21 8 port...Balls out power and speed, $120 lasts forever even if you cant tune..Here's a Link:


http://www.nitrohouse.com/catalog/pr...ducts_id=13197
__________________
nothing to see here................................
Jaz240 is offline   Reply With Quote
Old 03-15-2009, 05:36 AM   #6
Tech Adept
 
daniel15fl's Avatar
 
Join Date: Mar 2009
Posts: 148
Trader Rating: 3 (100%+)
Default motor

Quote:
Originally Posted by Tfizzle View Post
So i found a Ofna Ultra Comp2 the other day in the trash(im a garbageman). Brought it home and cleaned it up. I completely ripped the engine apart and cleaned it. I put it all back together and i cannot seem to get it to start.

The pull start was broke when i found it so ive been trying to start it with a start box that i found in the trash(love my job btw) previously.

I got another nitro truck so i know how to start an engine but this one wont go. Glow plug is bright orange hot. I turned the engine by hand till i got fuel in the line. Then a few more times to get fuel in the carb. Nothing. I think i see why they threw this thing away.

Now i have read that these Force engines are complete pieces of crap. This is the Force .26 btw.

What do you guys suggest? Just buy a new engine? if so, can you direct me towards a good replacement. Will my old pipe(assuming its the stock pipe) fit? Not going to be racing. Just bashing.

or should i keep messing with this one?
i understand where u r at with this, i bought a ofna ultra mbx from a guy for 50 bucks and yes the engines are pieces of shit. this one had a lot of rusty parts and what not, so i ordered all the parts i needed and threw in a Axial .28RR motor in it and it screams... i highly recomend it but the mach 427 would be good as well.... my suggestion is to keep messing with the enging for a couple more days and if u dont get ne thing out of it then it is time to replace
daniel15fl is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:36 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net