R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 02-01-2009, 01:12 PM   #1
Tech Rookie
 
Join Date: Feb 2009
Posts: 1
Angry slayer problem !!!!need help!!!!

well i was running my 3.3 slayer and it shut off the engine spins new spark plug but no start. it also pulls away when im starting it. like the clutch is stock or something. this is my firs rc car so dont know a lot about them. this is frustraiting today sunday and no toy......
slayer15 is offline   Reply With Quote
Old 02-01-2009, 01:16 PM   #2
Tech Apprentice
 
SPARTAN300gt's Avatar
 
Join Date: Jan 2009
Location: syracuse,ny
Posts: 63
Default

inspect your clutch and bearings sounds like its locked up, if it is it will stall whenn you hit the brakes
SPARTAN300gt is offline   Reply With Quote
Old 03-24-2009, 10:37 AM   #3
Tech Addict
 
SVTHOSER's Avatar
 
Join Date: Mar 2009
Location: Yucca Valley, CALIFORNIA
Posts: 612
Trader Rating: 43 (100%+)
Default

you may have cracked a piece off of the clutch shoe and probably got jammed it happened twice to the stock clutch on my slayer
SVTHOSER is offline   Reply With Quote
Old 03-24-2009, 11:45 AM   #4
Tech Regular
 
Krawl's Avatar
 
Join Date: Aug 2008
Location: Nitropia
Posts: 387
Default

It's probably hydro locked, the TRX 3.3 engine automatically locked itself when fuel is flooding inside...when this happen...take off your glow plug...cover the head with clean rag...and crank the engine with the EZ start until there is no fuel spitting...reinstall the plug then start the engine....good luck...btw visit traxxas website, go to their knowledge base section...I learned a lot of stuff there to tame my 3.3 maxx...also join their online community...lot of nice and helpful people there...
__________________
HPI Blitz EZRUN 60A + 6000kv + 2S + 4000mAh 25C
Jammin SCRT10 XERUN 120A + SP Silver Arrow V10 3.5R + 2S + 5800mAh 25C
Krawl is offline   Reply With Quote
Old 04-08-2009, 07:17 PM   #5
Tech Apprentice
 
infernus1986's Avatar
 
Join Date: Apr 2009
Location: Baltimore MD
Posts: 94
Default

Quote:
Originally Posted by SVTHOSER View Post
you may have cracked a piece off of the clutch shoe and probably got jammed it happened twice to the stock clutch on my slayer
yep i had the shoulder of one of the clutch shoes shatter on mine called traxxas they sent me 2 new clutches and 2 new glowplugs for nothing
infernus1986 is offline   Reply With Quote
Old 04-16-2009, 07:22 PM   #6
Tech Initiate
 
gixxer11's Avatar
 
Join Date: Apr 2009
Posts: 22
Default

Quote:
Originally Posted by Krawl View Post
It's probably hydro locked, the TRX 3.3 engine automatically locked itself when fuel is flooding inside...when this happen...take off your glow plug...cover the head with clean rag...and crank the engine with the EZ start until there is no fuel spitting...reinstall the plug then start the engine....good luck...btw visit traxxas website, go to their knowledge base section...I learned a lot of stuff there to tame my 3.3 maxx...also join their online community...lot of nice and helpful people there...

+1...happend to me
gixxer11 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:32 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net