R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 01-09-2009, 04:02 PM   #1
Tech Master
 
Join Date: May 2008
Posts: 1,771
Trader Rating: 7 (100%+)
Default WHAT is wrong with my servo?!

I am using an airtronics 94357 servo. I recently broke the plastic bottom gear and got it replaced. Problem is that when I plug it into my receiver and everyhting, the steering servo works fine but it seems like there isnt any current going to the throttle servo! What is happening? thanks!
__________________
Losi 8ight 1.5 ~ 8T ~ XXX Buggy ~ Mini-Baja

The o''le saying goes, pay me now, or pay me later, because you gonna pay me. "Pearl_414"
Chris__RC is offline   Reply With Quote
Old 01-09-2009, 05:23 PM   #2
K_B
Tech Master
 
K_B's Avatar
 
Join Date: Jul 2007
Location: Anchorage, Alaska
Posts: 1,434
Trader Rating: 69 (100%+)
Default

Which one had the broken gear? The throttle servo? If that's the case, then the motor is probably burned out on the servo.

If that isn't the case, then does the throttle servo work at all or is it just dead? If it doesn't work at all, check to make sure you plugged it in the correct direction. If it works but it's "weak", then again, it's probably a bad motor in the servo.

Try swapping in other servos and see if they do the same thing.
K_B is offline   Reply With Quote
Old 01-09-2009, 05:32 PM   #3
Tech Master
 
Join Date: May 2008
Posts: 1,771
Trader Rating: 7 (100%+)
Default

Quote:
Originally Posted by K_B View Post
Which one had the broken gear? The throttle servo? If that's the case, then the motor is probably burned out on the servo.

If that isn't the case, then does the throttle servo work at all or is it just dead? If it doesn't work at all, check to make sure you plugged it in the correct direction. If it works but it's "weak", then again, it's probably a bad motor in the servo.

Try swapping in other servos and see if they do the same thing.
It was for the throttle. I took it apart again and with the top case off, the gears spun!!!! So what would be my problem then?
__________________
Losi 8ight 1.5 ~ 8T ~ XXX Buggy ~ Mini-Baja

The o''le saying goes, pay me now, or pay me later, because you gonna pay me. "Pearl_414"
Chris__RC is offline   Reply With Quote
Old 01-09-2009, 08:20 PM   #4
Tech Adept
 
pantera nitro's Avatar
 
Join Date: May 2008
Location: Stanhope Gardens,Sydney, Australia
Posts: 209
Default

did u remove all the plug out of the receiver at all and possibly put them back in in the incorrect order?

when i changed radio systems i did this cos i was use to the way i would do it for my old JR but my new radio did it in a different order so i had plugged throttle into the 3rd or Aux port giving me no response.
__________________
MP9-TKI2/O.S. 21XZ-B V-Spec Speed
RC8T-CE/MG66X
RC8B-e/Hobby Wing
RC King Hobbies - onlinerc.com.au - Pro-Spec Race Bearings
pantera nitro is offline   Reply With Quote
Old 01-09-2009, 08:28 PM   #5
Tech Master
 
Join Date: May 2008
Posts: 1,771
Trader Rating: 7 (100%+)
Default

I had to take everything apart, AGAIN, and now it works!!!! For some reason I had to reverse my servo though!? But it all wokrs fine now!
__________________
Losi 8ight 1.5 ~ 8T ~ XXX Buggy ~ Mini-Baja

The o''le saying goes, pay me now, or pay me later, because you gonna pay me. "Pearl_414"
Chris__RC is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Spektrum DX3R Discussion Thread MadRacer Radio and Electronics 2015 05-10-2017 12:45 PM
Team Losi JRXS Kenshin Electric On-Road 13263 06-13-2016 03:39 PM
Repairing frayed servo leads Laterilus Electric On-Road 9 03-13-2006 07:34 PM
WTB: Spektrum Receiver jamescam R/C Items: Wanted to Buy 15 08-11-2005 12:29 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:51 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net