R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 12-16-2008, 06:03 PM   #1
Tech Regular
 
rdcracer's Avatar
 
Join Date: Feb 2008
Location: Tampa Fl
Posts: 460
Trader Rating: 4 (100%+)
Default Fried Spectrum reciever

I am stumped. i ran my new Losi 8 with JR 4750 for throttle. Spectrum 300 receiver. I ran great for a couple of tanks. I went to start it, engine raced and I realized to reception. I thought it was a bad switch. Put new spectrum switch turned it on and the receiver smoked and popped. I wnt over everything. All plugged in correctly. No bad or pinched wires. I unplugged the transponder and put in a new receiver. This time the throttle servo smoked and before I could shut it off the 2nd receiver smoked and popped. Great start getting back into Offroad. Been at this for 25 years in one way or another and have never seen anything like this. Took both servos out and put them on an old airplane receiver, neither worked but the throttle servo got very hot right away. Did not damage the receiver. Air servos worked before and after.
Didn't mean to run on but I am lost.
__________________
R & RC TIGHTWAD RACING
Where any price is too much.....

BMI 1/10 & 1/12 Copperhead
Scapel, Losi 22, Jammin SC10, Wraith
rdcracer is offline   Reply With Quote
Old 12-16-2008, 07:09 PM   #2
Tech Apprentice
 
Join Date: Apr 2008
Posts: 83
Trader Rating: 1 (100%+)
Default

I wouls contact Horizons service department and tell them what happened and send the reciever in to make sure it isnt messed up and im sure they will fix whats wrong or maybe send you another.
JHUDSON is offline   Reply With Quote
Old 12-16-2008, 07:18 PM   #3
Tech Master
 
CanyonCarverR1's Avatar
 
Join Date: Jan 2008
Location: NorCal
Posts: 1,340
Trader Rating: 13 (100%+)
Default

Any chance you are using a LiPo Rx battery with out a regulator?
CanyonCarverR1 is offline   Reply With Quote
Old 12-16-2008, 07:35 PM   #4
Tech Lord
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,484
Trader Rating: 8 (100%+)
Send a message via MSN to Integra
Default

spec receiver's are rated to 9V tho....so running a lipo would not cause that.
__________________
TNS Driver - Radio Post - Blue Groove Apparel - Team Panther - Hitec - Losi - W.E.D. Paint - Clockwork Fuel - Competition Heat - SUMO Racing - Tekin - Team Terribles - M2C Racing - Matrix Concepts - Kal Gard - BuKu Power - DE Racing -
Integra is offline   Reply With Quote
Old 12-17-2008, 03:13 AM   #5
Tech Fanatic
 
vladconnery's Avatar
 
Join Date: Jun 2008
Location: Charlotte, NC
Posts: 992
Trader Rating: 35 (100%+)
Default

Quote:
Originally Posted by Integra View Post
spec receiver's are rated to 9V tho....so running a lipo would not cause that.
I just learned something new.

thanks integra
__________________
KO PROPO EURUS
Kyosho: TKI3, TKIe Tekin RX8 Gen2
vladconnery is offline   Reply With Quote
Old 12-17-2008, 10:24 AM   #6
Tech Adept
 
teabag's Avatar
 
Join Date: Mar 2006
Location: Corona
Posts: 236
Trader Rating: 3 (100%+)
Default

what radio are you using? futaba?
__________________
Tristan
801xt
416
CR-01
teabag is offline   Reply With Quote
Old 12-17-2008, 10:35 AM   #7
Tech Rookie
 
Join Date: Nov 2008
Posts: 1
Default

I also smoked a Spektrum reciever. I believe I plugged it in backwards. On the big board there is a small, cube shaped, black component that all the smoke came from. The gentlemen at our local hobby shop adviced me to contact Spektrum. Voltage was about 5.6v.
Highpockets is offline   Reply With Quote
Old 12-17-2008, 10:38 AM   #8
Tech Adept
 
teabag's Avatar
 
Join Date: Mar 2006
Location: Corona
Posts: 236
Trader Rating: 3 (100%+)
Default

reason i'm asking if you use futaba radios is because if you have it in the HRS mode it may mess your receiver and non digital servo's up. I did this with my 3pks/faast system, it was in HRS mode and I had a non digital servo in it and it burnt out the servo practically when I turned it on. Stumped me for awhile till i figured it out. Didn't burn the receiver though.
__________________
Tristan
801xt
416
CR-01
teabag is offline   Reply With Quote
Old 12-17-2008, 12:31 PM   #9
Tech Lord
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,484
Trader Rating: 8 (100%+)
Send a message via MSN to Integra
Default

Quote:
Originally Posted by teabag View Post
reason i'm asking if you use futaba radios is because if you have it in the HRS mode it may mess your receiver and non digital servo's up. I did this with my 3pks/faast system, it was in HRS mode and I had a non digital servo in it and it burnt out the servo practically when I turned it on. Stumped me for awhile till i figured it out. Didn't burn the receiver though.


when he said.."i ran my new Losi 8 with JR 4750 for throttle. Spectrum 300 receiver."....that would imply he is running Spec gear.
__________________
TNS Driver - Radio Post - Blue Groove Apparel - Team Panther - Hitec - Losi - W.E.D. Paint - Clockwork Fuel - Competition Heat - SUMO Racing - Tekin - Team Terribles - M2C Racing - Matrix Concepts - Kal Gard - BuKu Power - DE Racing -
Integra is offline   Reply With Quote
Old 12-17-2008, 12:31 PM   #10
Tech Prophet
 
houston's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2004
Location: portland OR
Posts: 15,099
Trader Rating: 91 (100%+)
Default

make sure you pay attention to the insignias on the receiver that tell you which wire is pos. , neg. and signal especially with lipo
__________________
TEAM FUSION X ENGINES / TEAM BYRON ORIGINALS / TEAM PROLINE RACING TIRES / TEAM SICK GRAPHICS /TEAM KYOSHO / things I support: COMP HEAT DEALER /TEAM LUNSFORD/ FUSIONX™ USA / TEAM KYOSHO / "H.E.S."™ / BYRON FUELS / RC-OMGUSA/KICWEBDESIGNZ/AKA TIRES/PROLINE RACING TIRES /RAYA RACING/BUKU POWER CLUTCH/M2CRACING/special thanks to STAV and JIM HOTTIGREENMOUNTAINGRILLS.COM
houston is offline   Reply With Quote
Old 12-17-2008, 05:12 PM   #11
Tech Regular
 
rdcracer's Avatar
 
Join Date: Feb 2008
Location: Tampa Fl
Posts: 460
Trader Rating: 4 (100%+)
Default

Thanks for the responses
It is a Spectrum transmitter, I checked and double checked all connections and made sure no wires were pinched. The only thing I havent checked is the switch which I am going to do now. I am using a standard AA NiMH 4 cell.
Any more Ideas
__________________
R & RC TIGHTWAD RACING
Where any price is too much.....

BMI 1/10 & 1/12 Copperhead
Scapel, Losi 22, Jammin SC10, Wraith
rdcracer is offline   Reply With Quote
Old 12-17-2008, 05:43 PM   #12
Tech Lord
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,484
Trader Rating: 8 (100%+)
Send a message via MSN to Integra
Default

Get a Hump pack at a Minimum.
__________________
TNS Driver - Radio Post - Blue Groove Apparel - Team Panther - Hitec - Losi - W.E.D. Paint - Clockwork Fuel - Competition Heat - SUMO Racing - Tekin - Team Terribles - M2C Racing - Matrix Concepts - Kal Gard - BuKu Power - DE Racing -
Integra is offline   Reply With Quote
Old 12-17-2008, 05:51 PM   #13
Tech Addict
 
Join Date: Dec 2007
Posts: 622
Trader Rating: 37 (100%+)
Default

you said the servo got hot? maybe the motor is bad in the servo causing a short and frying the reciever. Just a thought.
chrisjohns is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to instantly fry your Novak GTB Spread Spectrum? TeQ Radio and Electronics 189 05-14-2011 01:58 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:24 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net