R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 09-07-2008, 05:29 PM   #1
Tech Initiate
 
Join Date: Mar 2008
Location: Huntington, ny
Posts: 42
Send a message via AIM to mrwuffles
Default Pull start problem

My xt2 pull start spring came undone and now when i wind the string back on the drum and put it all back together it will recoil but not un less the cover screws arent fully tightened i cant figure it out ive tried so many times and cant figure it out.
mrwuffles is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rc10ntc3 Taz_S Nitro On-Road 9437 05-28-2017 08:13 PM
STS .28 pull-start engine dino.tw Onroad Nitro Engine Zone 632 08-31-2009 06:10 AM
2nd cracked case.. engine mount problem. any suggestions? builtb16a Nitro Off-Road 39 08-15-2009 12:44 AM
Why is traxxas so much better than OFNA? sokar Nitro Off-Road 47 07-01-2009 08:45 PM
Ofna Cd-3 penggoy Nitro On-Road 1551 01-14-2008 06:46 PM
*Servo/PT Problem* tc3blue Electric On-Road 16 08-12-2005 05:48 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:59 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net