R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 09-02-2008, 09:32 PM   #16
Tech Addict
 
crazyjr's Avatar
 
Join Date: Jul 2005
Location: middle georgia
Posts: 613
Default

Quote:
Originally Posted by thecman26 View Post
Stretched rod? Really?
cause I thought it was "normal".
All my engines feel that way at TDC.
One has a brand new rod in it!
Same here, I've had traxxas (3.3)and O.S. (.21 v-spec and .12 tr and TG) all felt that way and run long after that feeling set in. never blew or run bad, I haven't run them in a while I may rebuild them before running again. Thanks to all for the heads up on possible rod stretch
crazyjr is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vandals hit small club track... kamlooper Racing Forum 39 04-09-2008 07:11 PM
BEWARE OF THIS BUYER ANTHONY BALLARD @ RCTECH NICK: pimpjuice_101 Guo Chean Buyer/Seller dispute and Feedback discussion forum 298 07-17-2006 09:12 PM
I don't normaly post things like this but it kinda make sense Davin Chat Lounge 25 05-11-2005 06:18 AM
The Great Magazine Debate DerekB Chat Lounge 107 06-15-2004 02:33 PM
Bad Service From Aussie Retailers watsrags Australian Racing 29 09-09-2003 05:12 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:09 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net