R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 08-25-2008, 02:03 PM   #1
Tech Adept
 
Join Date: Jan 2008
Posts: 132
Default Clutch Slipping sound or servo going?

I was just out running my buggy and I found it still at medium rev without me giving it any throttle. Is this a problem with the servo or clutch? Almost sound it like it was going to run away if I didn't hit the breaks.

Buggy is an RC8 with a OS V-Spec with a gallon of Nitro on the Motor.

Pete
Captpete is offline   Reply With Quote
Old 08-25-2008, 02:14 PM   #2
K_B
Tech Master
 
K_B's Avatar
 
Join Date: Jul 2007
Location: Anchorage, Alaska
Posts: 1,434
Trader Rating: 69 (100%+)
Default

A clutch problem usually causes stalling. My guess is that the carb is sticking or your servo is going.

With the body off and wheels off the ground, hit the gas a few times and see if the throttle returns to it's neutral position. If it doesn't, well, the servo very well could be toast.

If it does return to center but it the motor doesn't go back to idle, then the carb might be gummed up somewhat and it's sticking open or you may need a stiffer spring on the throttle linkage. Some sort of secondary throttle return spring is a good idea as well.
K_B is offline   Reply With Quote
Old 08-25-2008, 08:54 PM   #3
Tech Elite
 
Jammin57's Avatar
 
Join Date: Aug 2006
Posts: 2,374
Trader Rating: 120 (100%+)
Default

When you hit the brakes does the motor go back down to normal idle???
If it does then youre carb is not closing all the way when you just let off the throttle and then when you hit the brakes the servo is forcing it closed

If the motor runs normal and then idles up real high like you are on the throttle then you could have a front bearing leaking
When it leaks the motor will suck in air causing it to lean out and rev up

Last edited by Jammin57; 08-25-2008 at 09:00 PM. Reason: added
Jammin57 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
stranger sound with servo HITEC 625MG in vendetta xsxboy Micro and Mini Scales 3 07-30-2008 06:32 AM
Help w/Slipping PLEASE "Spanky Electric Off-Road 11 07-14-2008 07:41 PM
buzzing sound from old servo Molala3 Electric On-Road 1 04-20-2008 10:34 AM
Brand New Sound Blaster Audigy 2 ZS 7.1 surround sound semore Other Items: For Sale/Trade or Wanted to Buy 7 04-14-2006 10:32 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:25 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net