R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 07-07-2008, 06:23 PM   #1
Tech Apprentice
 
Join Date: Jun 2008
Location: Australia
Posts: 93
Trader Rating: 1 (100%+)
Default O.S 28xz Snapped crank (with pics)

I have had it with my O.S 28xz, its been nothing but trouble from day 1.
First it was the carby that was dodgy from the factory (would run really rich with the LSN turned all the way in).
Then it needed a new conrod rod after 10 litres (fair enough general wear and tear).
Now the end of the crank has snapped off.
I was 3 laps into my 1st heat for the day, when the engine stopped.
The engine has done 13 litres. I run it in a Hyper ST
Any ideas why this might have happened?
I dont know whether to put a new crank in it or just get a new engine. What do you think?
I wont be buying an O.S again.




From the back of the flywheel.
herb99 is offline   Reply With Quote
Old 07-07-2008, 07:39 PM   #2
Tech Elite
 
ezveedub's Avatar
 
Join Date: Aug 2004
Location: Fort Lauderdale, FL
Posts: 2,411
Trader Rating: 14 (100%+)
Send a message via AIM to ezveedub Send a message via Yahoo to ezveedub
Default

Did this engine have a spacer washer behind the collet? It seems right at the end where the threads stop there is some marks like the flywheel nut bottomed out slightly on the shank and when the nut was tightened, it applied more force on the crank end than it should have to get the flywheel tight. With a spacer installed to push the collet farther into the flywheel, it may have stopped the nut from bottoming out. Just one idea of what may have happened.
__________________
Kyosho, Mugen Seiki, Maxy's Fuel, KO Propo
O.S., Ninja JX, Novarossi, RMV
ezveedub is offline   Reply With Quote
Old 07-07-2008, 07:43 PM   #3
Tech Elite
 
allan42r's Avatar
 
Join Date: Jun 2008
Location: OSWEGO IL.
Posts: 2,602
Default

did the motor get pushed into the cb? 1st os crank ive seen break like that. my buddy's and mine were easy to breakin, tune, and run great. send your motor in to os, they stand behind there product.
__________________
Pinky kisses better than mason's mom
allan42r is offline   Reply With Quote
Old 07-07-2008, 08:55 PM   #4
Tech Apprentice
 
Join Date: Jun 2008
Location: Australia
Posts: 93
Trader Rating: 1 (100%+)
Default

Nah it didnt have a spacer behind the collet. It seems like there would have to be a huge sideways force put on the crank to do this.
It didnt get pushed into the clutch bell, the clutch bell has no damage.
Both front and rear engine bearings are in great shape with no slop.
Mesh was not too tight, other wise the clutch bell would be chewed up.
herb99 is offline   Reply With Quote
Old 07-07-2008, 10:25 PM   #5
Tech Champion
 
Tony Newland's Avatar
 
Join Date: May 2005
Location: Utah
Posts: 5,764
Trader Rating: 50 (100%+)
Default

Its probably an isolated inident..... a buddy runs one in his STRR and its rediiiccccuuulous

If you bought it new, try contacting OS directly and see what they say.
__________________
Schumacher Factory Team - Core RC - Highest Servos - Avid - Lunsford - Bellgate Distributors - Jconcepts - www.Prime-hobby.com - IRCR
Tony Newland is offline   Reply With Quote
Old 07-07-2008, 11:17 PM   #6
Tech Rookie
 
Join Date: Apr 2008
Location: kalihi, hawaii
Posts: 11
Default

sorry to hear that you won't buy O.S. again. all i ever bought was O.S. engine. i never had any problems. i dont own a 28 xz yet, but all i heard about it was all good comments and how it rips. anywayz goodluck with the next engine.. dont give up on O.S...
__________________
Is waiting........
shoxone808 is offline   Reply With Quote
Old 07-07-2008, 11:25 PM   #7
Tech Regular
 
smracer31's Avatar
 
Join Date: Nov 2004
Location: Wisconsin
Posts: 425
Trader Rating: 6 (100%+)
Send a message via AIM to smracer31
Default

did you crash or anything prior to that? seems strange.. i could see the chassis flexing enough to perhaps allow the spur gear to hit the chassis and possible snap the shaft.. but that would be pretty extreme. did you check the bearings on the clutch bell? if you have one explode and lock the spur at a high rpm, then when you go to brake say at the end of the straight, the force might be strong enough to break the shaft.. either way its very odd.
smracer31 is offline   Reply With Quote
Old 07-08-2008, 01:48 AM   #8
Tech Apprentice
 
Join Date: Jun 2008
Location: Australia
Posts: 93
Trader Rating: 1 (100%+)
Default

I didnt crash or do anything that might have caused this.
The engine is in a Hyper ST Pro and they have really thick chassis and center braces. I cant see it being chassis flex.
Front clutch bell bearing was on the way out but still spinning ok after the crank breaking.
Its anoying as all the replacement parts I have had to put on it I could have almost bought a new engine. Others that I know that have this engine are replacing the crank and or conrod after 2 gallons.
If you pay for a quality engine you would like it to last longer than say a RTR engine.
herb99 is offline   Reply With Quote
Old 07-08-2008, 08:43 AM   #9
Tech Elite
 
allan42r's Avatar
 
Join Date: Jun 2008
Location: OSWEGO IL.
Posts: 2,602
Default

sorry to hear about your motor but i know os would of taken care of this.
__________________
Pinky kisses better than mason's mom
allan42r is offline   Reply With Quote
Old 07-08-2008, 12:41 PM   #10
Tech Champion
 
Tony Newland's Avatar
 
Join Date: May 2005
Location: Utah
Posts: 5,764
Trader Rating: 50 (100%+)
Default

Quote:
Originally Posted by herb99 View Post
I didnt crash or do anything that might have caused this.
The engine is in a Hyper ST Pro and they have really thick chassis and center braces. I cant see it being chassis flex.
Front clutch bell bearing was on the way out but still spinning ok after the crank breaking.
Its anoying as all the replacement parts I have had to put on it I could have almost bought a new engine. Others that I know that have this engine are replacing the crank and or conrod after 2 gallons.
If you pay for a quality engine you would like it to last longer than say a RTR engine.
crank and con rod after 2 gals? wow thats hard on parts, I didnt think anyone could abuse and engine worse than me and I'm getting at least 4 gals out of any of my Vspecs racing the hell out of em every weekend......... I'd take a look at what fuel your running and evaluate the abuse your subjecting it to........ thats barely broken and loosened enough to gain good RPM and take agood tune IMO, I just bought a Mugen JX21 which is basically a 5 port vspec/speed mix and its got a gallon on it and it still gets stuck at TDC cold
__________________
Schumacher Factory Team - Core RC - Highest Servos - Avid - Lunsford - Bellgate Distributors - Jconcepts - www.Prime-hobby.com - IRCR
Tony Newland is offline   Reply With Quote
Old 07-08-2008, 04:41 PM   #11
Tech Apprentice
 
Join Date: Jun 2008
Location: Australia
Posts: 93
Trader Rating: 1 (100%+)
Default

They are all developing slop between the conrod and the crank pin
If you dont change the conrod early enough the the pin on the crank wears as well.
Parts are so expensive for these things, you would think they made them to last.
herb99 is offline   Reply With Quote
Old 07-08-2008, 04:50 PM   #12
Tech Elite
 
jamminnay's Avatar
 
Join Date: Apr 2008
Location: IL
Posts: 2,012
Trader Rating: 10 (100%+)
Send a message via AIM to jamminnay Send a message via MSN to jamminnay
Default

this is the first time i havve ever seen this happen to an os motor.. i am sure there had to hae been something that caused this. i just dont know what it was
jamminnay is offline   Reply With Quote
Old 07-09-2008, 05:44 AM   #13
Tech Champion
 
Maximo's Avatar
R/C Tech Elite Subscriber
 
Join Date: Jan 2005
Posts: 7,900
Trader Rating: 11 (100%+)
Default

So I wonder what OS has to say about this crank...I see this exact post on every forum avaialble, yet i see zero mention of what OS has said... I honestly hope you talked to OS about possible warranty before you came online trashing OS on every forum..
Maximo is offline   Reply With Quote
Old 07-09-2008, 06:23 AM   #14
Tech Apprentice
 
Join Date: Jun 2008
Location: Australia
Posts: 93
Trader Rating: 1 (100%+)
Default

Read my reply on truggyracers. There is no warranty.
herb99 is offline   Reply With Quote
Old 07-09-2008, 06:36 AM   #15
Tech Champion
 
Maximo's Avatar
R/C Tech Elite Subscriber
 
Join Date: Jan 2005
Posts: 7,900
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by herb99 View Post
Read my reply on truggyracers. There is no warranty.
OS will warranty something like that I am sure...... what did they say when you contacted them ? or did you even contact them ?
Maximo is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ever Snap a Crank? Pics inside GroffBall Nitro Off-Road 32 11-01-2007 04:37 PM
WTB: HV-Maxx rotors with snapped off shafts ta_man R/C Items: Wanted to Buy 1 08-27-2007 11:49 AM
snapped my xxx-cr buggy xXRAUDELXx Electric Off-Road 6 04-19-2007 05:23 PM
STS 30 modded crank pics Maximo Onroad Nitro Engine Zone 20 01-18-2007 06:26 AM
Fantom FR18 For Sale 1 QUART Detailed Pics, Piston, Sleeve, Crank, etc. Izze-Racing R/C Items: For Sale/Trade 0 03-02-2006 06:50 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:52 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net