R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 07-07-2008, 06:13 PM   #1
Tech Regular
 
Join Date: Mar 2008
Location: Boise
Posts: 320
Default First impressions of my Gen 5 Go 7 port!

Some of you might remember me posting a while back on my first impressions of a Go 3 'sport'. I love that motor, but after 9 gallons, it's getting a bit tired. Still runs good mind you, but I would rather have it as a spare then have it die on a race day.

So I decided to upgrade to a Go 7 port. Just ordered it and got it in the mail so its the Gen 5 version. However I think it might have the shorter LSN, not sure.

Just looking at it out of the box I already like what I see. The idle screw is on top of the carb and I also like the etching on the head. I did a quick inspection of the internals and everything looked ok. No shavings or what have you. With the head off I did notice that the piston stopped halfway up the sleeve...

On to break in.. I knew before hand that I would need a heat gun so picked one up last week. I didn't know that it was going to be such a PITA to break in though. I don't know if it was just me, but it took me an HOUR to get through the first tank trying to idle. The pinch is just unreal. For the second tank I just plopped it on the ground and started driving it... even then it was hard to keep going.

I was still having problems on the 3rd tank so I swapped out the plug and problem solved. For the next 4-5 tanks I drove it real fat in the parking lot at around 210 degrees. After that I put it on the track, and started leaning it out. I must say, the tuning window with these engines is SMALL.

I got through about 3/4's of a gallon today and it still didn't want to rev, which I've read before so no big deal. What surprised me is that, without the heat gun it wouldn't start. Even past half a gallon it was locking up.

As far as the LSN/carb issues I've been reading about... No problems here! I've also read that the 7 ports didn't have much bottom but again I didn't feel it was lacking at all. What I really liked is that it NEVER hit max rpm. I just like knowing its there.

If anyone is curious im running Byrons Gen 2 25% 11% with a JP-2.



I forgot to add, I was temping between 260 and 280 after the half gallon mark. Anything colder than that and it pretty much wouldn't run. This was in 95 degree dry weather.

Last edited by Furadi; 07-07-2008 at 06:30 PM.
Furadi is offline   Reply With Quote
Old 07-07-2008, 08:59 PM   #2
Tech Elite
 
22Racer's Avatar
 
Join Date: Mar 2002
Location: Wanamingo Mn
Posts: 3,078
Trader Rating: 67 (100%+)
Default

I've found that if you are having trouble with a Go running during break in it's usually a bad plug or not a hot enough plug. (as you found)
We tried the 0801 pipe and it is awesome on this motor, even the speed v-specs wont out power you on the straight. The 0801 pipe has good bottom end too.

Rex
__________________
Rw modding and engine repair http://www.rw-mods.com
Sleeve resizing $15.00/ motor rebuild $30.00
Argus engine distributor/Avid bearings/ Alpha engines/
Fx Royal engines/ Maxy Engines
e-mail rwmods@yahoo.com Rex Welch
22Racer is offline   Reply With Quote
Old 07-07-2008, 09:17 PM   #3
Tech Regular
 
Join Date: Mar 2008
Location: Boise
Posts: 320
Default

Quote:
Originally Posted by 22Racer View Post
I've found that if you are having trouble with a Go running during break in it's usually a bad plug or not a hot enough plug. (as you found)
We tried the 0801 pipe and it is awesome on this motor, even the speed v-specs wont out power you on the straight. The 0801 pipe has good bottom end too.

Rex
I may try one some day, the RC budget is getting slim So should the temps drop some when the metal pinch has worn down?
Furadi is offline   Reply With Quote
Old 07-08-2008, 08:23 AM   #4
Tech Addict
 
gubbs3's Avatar
 
Join Date: Aug 2006
Location: MN
Posts: 600
Trader Rating: 6 (100%+)
Default

Quote:
Originally Posted by Furadi View Post
I may try one some day, the RC budget is getting slim So should the temps drop some when the metal pinch has worn down?
On any engine the tune (and temp) will jump all over the place until the last of the metal pinch is gone. That's also most likely the reason the engine won't fully wind out.
gubbs3 is offline   Reply With Quote
Old 07-08-2008, 08:30 AM   #5
Tech Regular
 
Join Date: Mar 2008
Location: Boise
Posts: 320
Default

Quote:
Originally Posted by gubbs3 View Post
On any engine the tune (and temp) will jump all over the place until the last of the metal pinch is gone. That's also most likely the reason the engine won't fully wind out.
Gotcha, this is my first new 'race' engine so not sure what to expect.
Furadi is offline   Reply With Quote
Old 07-08-2008, 08:38 AM   #6
Tech Initiate
 
wenotlast's Avatar
 
Join Date: Jun 2008
Location: florence,alabama
Posts: 32
Default

keep running her my pinch finally broke after a 1 1/2 gallons on my 5port turbo. after it did no more heat gun. i was running a o.s. p7 and had the same problem, it didnt want to stay running, swapped to a p3 and man it was a diffrence.
__________________
hyper 8.5 pro
trinity moster horepower fuel
GO tech .21 5port turbo

In Loving Memory of Braxton Lee Harville 2/22-3/30/07
wenotlast is offline   Reply With Quote
Old 07-08-2008, 03:16 PM   #7
Tech Master
 
kd2777's Avatar
 
Join Date: Apr 2007
Posts: 1,439
Trader Rating: 128 (99%+)
Default

Keep in mind that a rod for that engine is under 20 bucks. That much pinch, though it makes for a long lasting engine is hell on a con rod. As soon as it is gone at the gallon and half mark replace the rod and save the life of your engine.
kd2777 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Duratrax Evader ST Pro - Impressions? nozauta619 Electric Off-Road 3 07-30-2014 06:25 AM
Novarossi 21+5, 21BF 3-port, & GO Tech .21 7-port Turbo!!! $110 shipped!! HoustonAreaRC R/C Items: For Sale/Trade 5 08-05-2008 09:30 AM
First impressions of my 3 port Go-Tech. (non R spec) Furadi Nitro Off-Road 20 04-03-2008 10:17 PM
Savage X SS Impressions? surreal Monster Trucks 7 10-15-2006 05:30 PM
What are your impressions on a Ta04-pro? Inspire Electric On-Road 6 02-16-2004 05:32 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:25 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net